Versionen dieses Beitrags

@media funktioniert am PC Bildschirm, aber nicht am Smartphone

Thepoeppel crop Rolf B
  • @media funktioniert am PC Bildschirm, aber nicht am Smartphone
  • Hallo Eddi,
  • so, jetzt hab ich's. Das frameset ist tatsächlich das Problem, bzw. der Mangel der meta viewport Angabe in der frameset Seite.
  • so, jetzt hab ich's. Das frameset ist tatsächlich das Problem, bzw. der Mangel der meta viewport Angabe in der frameset Seite.
  • Dadurch ist der Body mit 980px Breite unterwegs. Ruf mal gättner.de auf dem Smartphone auf statt wahlkreis149.de - und dann ändere ganz schnell dein width:70em für den body auf max-width:70em.
  • Und ich habe was gelernt: Chrome auf dem Smartphone kann man via USB Kabel mit Chrome auf dem Desktop debuggen. Bin nie auf die Idee gekommen, dass das gehen könnte. Jedenfalls weiß ich dadurch jetzt das folgende:
  • Danach kannst Du anfangen, die Monsterfonts zu fixen 😀
  • Der Body ist mit 980px Breite unterwegs. Ruf mal gättner.de auf dem Smartphone auf statt wahlkreis149.de - dann ist das frameset nicht dazwischen und die viewport-Angabe greift.
  • Ändere also bitte width:70em für den body auf max-width:70em. Danach kannst Du anfangen, für die Smartphone-Darstellung die Monsterfonts zu fixen 😀
  • Irgendwer muss doch für Dich wahlkreis149.de betreiben bzw. diese frame-Pseudoweiterleitung eingerichtet haben. Diese(r) jemand muss jetzt mithelfen und die meta viewport Angabe auch im frameset hinzufügen. ODER gleich die Frameset Seite durch einen Redirect nach gättner.de ersetzen. Danach kannst Du Dich dann an die Arbeit machen, um eine ordentliche Anzeige für das Smartphone hinzubekommen.
  • _Rolf_
  • --
  • sumpsi - posui - clusi