Antwort an „Klaus1“ verfassen

Hallo,

ich habe die PHP-Version eines Webservers von 7.2 auf 7.4 aktualisiert. Danach muss ich (leider) auch immer das SAPRFC-Modul neu kompilieren, damit es läuft. Allerdings hat es diesmal nicht funktioniert. Nach dem Update auf 7.4 musste ich erstmal wieder die php.ini anpassen, aber das ist wohl Nebensache. Dann habe ich noch php74-devel installiert, damit ich Zugriff auf phpize bekomme. Danach habe ich wieder die vorhandenen Sourcen neu kompiliert

phpize
./configure
make
make install

Und im conf.d vom php74 den ini-Eintrag erstellt.

Dennoch meckert PHP beim Start:

Module compiled with module API=20170718
PHP    compiled with module API=20190902

Weiß jemand, wie ich das gerade biegen kann? Hab ich die falsche phpize-Version verwendet oder wovon hängt es ab, welche Modul-API genutzt wurde?

LG Klaus

freiwillig, öffentlich sichtbar
freiwillig, öffentlich sichtbar
freiwillig, öffentlich sichtbar

Ihre Identität in einem Cookie zu speichern erlaubt es Ihnen, Ihre Beiträge zu editieren. Außerdem müssen Sie dann bei neuen Beiträgen nicht mehr die Felder Name, E-Mail und Homepage ausfüllen.

abbrechen