Antwort an „Raketenwilli“ verfassen

Zu Deiner Beruhigung. Das erinnert mich an meine, anno asbach vorgenommenen Versuche, unter SuSE das Modul rewrite zu laden. Ich hatte 4 Versuche gebraucht, um in der httpd.conf die folgende Zeile wahrernstzunehmen

# DO NOT EDIT! ...

Also erstmal werden nicht mehr alle Links aus sites-enabled eingesammelt, sondern nur noch die mit der Endung *.conf

Hm. Das steht eigentlich schon sehr lange Zeit unmissverständlich in der apache2.conf drin:

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#       /etc/apache2/
#       |-- apache2.conf
#       |       `--  ports.conf
#       |-- mods-enabled
#       |       |-- *.load
#       |       `-- *.conf
#       |-- conf-enabled
#       |       `-- *.conf
#       `-- sites-enabled
#               `-- *.conf

und dann auch noch:

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

#...

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

Und damit man das nicht falsch macht gibt es sogar folgendes Befehle:

a2enmod   a2dismod   #Module ein - oder ausschalten
a2enconf  a2disconf  #Configs ein - oder ausschalten 
a2ensite  a2dissite  #virt. Hosts ein - oder ausschalten

die beraten dann auch, ob ein Neustart oder nur ein Reload notwendig ist.

freiwillig, öffentlich sichtbar
freiwillig, öffentlich sichtbar
freiwillig, öffentlich sichtbar

Ihre Identität in einem Cookie zu speichern erlaubt es Ihnen, Ihre Beiträge zu editieren. Außerdem müssen Sie dann bei neuen Beiträgen nicht mehr die Felder Name, E-Mail und Homepage ausfüllen.

abbrechen