Versionen dieses Beitrags

.htaccess

ursus contionabundo
  • .htaccess
  • > [Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte](https://forum.selfhtml.org/self/2019/mar/23/punkt-htaccess/1745195#m1745195). Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • **Dann will ich mal…**
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\.a) Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +Includes
  • AddOutputFilter INCLUDES .html .htm
  • ~~~
  • 1.b)
  • Das hier sollte nicht nötig sein:
  • ~~~Apache
  • AddType text/html .html .htm
  • ~~~
  • 2\.)
  • Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\.a) Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 3\.b) Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +Includes
  • AddOutputFilter INCLUDES .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün. **Außerdem muss sich jemand diese Dateien ansehen!**

.htaccess

ursus contionabundo
  • .htaccess
  • > [Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte](https://forum.selfhtml.org/self/2019/mar/23/punkt-htaccess/1745195#m1745195). Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • **Dann will ich mal…**
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • 1\.a) Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +Includes
  • AddOutputFilter INCLUDES .html .htm
  • ~~~
  • 1.b)
  • Das hier sollte nicht nötig sein:
  • ~~~Apache
  • AddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • 2\.)
  • Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • 3\.a) Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • 3\.b) Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +Includes
  • AddOutputFilter INCLUDES .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün. **Außerdem muss sich jemand diese Dateien ansehen!**

.htaccess

ursus contionabundo
  • .htaccess
  • > [Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte](https://forum.selfhtml.org/self/2019/mar/23/punkt-htaccess/1745195#m1745195). Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • **Dann will ich mal…**
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +Includes
  • AddOutputFilter INCLUDES .html .htm
  • ~~~
  • Das hier sollte nicht nötig sein:
  • ~~~Apache
  • AddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +Includes
  • AddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün. **Außerdem muss sich jemand diese Dateien ansehen!**

.htaccess

ursus contionabundo
  • .htaccess
  • > [Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte](https://forum.selfhtml.org/self/2019/mar/23/punkt-htaccess/1745195#m1745195). Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • **Dann will ich mal…**
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • Options +Includes
  • AddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • Options +Includes
  • AddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün. **Außerdem muss sich jemand diese Dateien ansehen!**

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • > [Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte](https://forum.selfhtml.org/self/2019/mar/23/punkt-htaccess/1745195#m1745195). Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • **Dann will ich mal…**
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün. **Außerdem muss sich jemand diese Dateien ansehen!**

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün.
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün. **Außerdem muss sich jemand diese Dateien ansehen!**

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast, dann dann füge noch
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast in welchen sich etwas wie `<?php … ?>` oder die "Kurzschreibweise" `<? … ?>` findet, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün.

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht!
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht! Deshalb mache ich das nicht grün.

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER https nicht verwendet wird. Das reapairere ich und schalte es an:
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER (deshalb füge ich ein `[OR]` ein) https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht!

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on
  • RewriteCond %{HTTPS} !=on [OR]
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht!

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen wahrscheinlich gefährlich unsicher , noch wahrscheinlicher ist es, dass das gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen gefährlich unsicher, wahrscheinlich ist aber sogar, dass das deinstalliert wurde und also gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht!

.htaccess

ursus contionabundo
  • .htaccess
  • > Ich würde mich sehr freuen, wenn ihr mich heute weiter helfen könnte. Rolf hat netterweise die htaccess ordentlich hingestellt damit man es lesen kann.
  • Dann will ich mal.
  • ~~~apache
  • # SSI(Server Side Include)-Files
  • # AddType text/x-server-parsed-html .shtm .shtml .htm .html
  • Options +IncludesAddType text/html .html .htm
  • AddOutputFilter INCLUDES .html .htm
  • AddType x-mapp-php4 .kico4u
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • Die Zeile mit dem # sind Kommentare, wirken also nicht.
  • 1\. Wenn Du Dateien mit der Endung ".shtml" oder "shtm" hast und/oder sich in Deinem Dateien etwas wie
  • ~~~html
  • <!--#include file="header.shtml" -->
  • ~~~
  • findet, dann notiere
  • findet, dann (und nur dann!) notiere
  • ~~~apache.,good
  • Options +IncludesAddType text/html .html .htm
  • ~~~
  • 2\. Diese Einstellung soll dafür sorgen, dass PHP4 verwendet wird. Das ist sehr alt und inzwischen wahrscheinlich gefährlich unsicher , noch wahrscheinlicher ist es, dass das gar nicht mehr geht. Entferne das und repariere ggf. den Webauftritt.
  • ~~~apache,bad
  • AddType x-mapp-php4 .kico4u
  • ~~~
  • Hinweis hierzu: Wahrscheinlich wird [magic_quotes_gpc()](http://php.net/manual/de/security.magicquotes.php) benutzt. Ich wüsste sonst keinen Anlass (nicht: Grund) an der alten und ungepflegten PHP-Version festzuhalten. **Da hat jemand echt miese Arbeit geleistet.**
  • 3\. Das sind die Regeln für die Weiterleitung zu https:
  • ~~~apache,bad
  • # RewriteEngine On
  • # RewriteCond %{SERVER_PORT} !=443
  • # RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • # RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Es soll also zu https://www.mywebsite.de weitergeleitet werden, wenn der Hostname nicht "www.mywebsite.de" ist ODER https nicht verwendet wird. Das reapairere ich und schalte es an:
  • ~~~apache,good
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • 4\. Das hier brauchen wir dann nicht mehr, es ist hyperliquid:
  • ~~~~apache,bad
  • RewriteEngine On
  • RewriteCond %{HTTP_HOST} !^kico4u\.de$ [NC]
  • RewriteRule ^(.*)$ https://mywebsite.de/$1 [R=301,L]
  • ~~~
  • **Bauen wir das, unter Verzicht auf das gefährliche und wohl auch längst nicht mehr funktionierende PHP 4 zusammen:**
  • ~~~apache,good
  • # Enable Server-Side-Includes
  • Options +IncludesAddType text/html .html .htm
  • # Redirect all unsafe requests
  • # and requests witheout the 'www' to https://www.mywebsite.de/
  • RewriteEngine On
  • RewriteCond %{HTTPS} !=on
  • RewriteCond %{HTTP_HOST} !^www.mywebsite.de$
  • RewriteRule (.*)$ https://www.mywebsite.de/$1 [R=301,L]
  • ~~~
  • Wenn Du wirklich Dateien mit der Endung ".kico4u" hast, dann dann füge noch
  • ~~~
  • AddHandler application/x-httpd-php .kico4u
  • ~~~
  • hinzu um diese Datein durch die vom Hoster voreingestellte und also hoffentlich noch gepflegte Version von PHP abarbeiten zu lassen. Empfehlen würde ich das aber nicht!