Versionen dieses Beitrags

Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.

ursus contionabundo
  • Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.
  • Also, liebewinter. [Das Skript funktioniert](https://forum.selfhtml.org/self/2019/may/11/phpmyadmin-nicht-start/1748683#m1748683), das habe ich getestet. Natürlich musst Du Deine Zugangsdaten eintragen.
  • Vielleicht ist Deine Datentabelle "mela" anders als meine:
  • ~~~sql
  • DROP TABLE IF EXISTS `mela`;
  • CREATE TABLE `mela` (
  • `name` tinytext,
  • `email` tinytext,
  • `message` text,
  • `datetime` datetime DEFAULT NULL,
  • `ip` tinytext,
  • KEY `datetime` (`datetime`),
  • FULLTEXT KEY `name` (`name`),
  • FULLTEXT KEY `email` (`email`),
  • FULLTEXT KEY `message` (`message`),
  • FULLTEXT KEY `ip` (`ip`)
  • ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;
  • ~~~
  • Immerhin war ja bei Dir die IP ein Integer, also eine Zahl - was FALSCH ist.
  • Immerhin war ja bei Dir die IP ein Integer, also eine Zahl - was FALSCH ist.
  • Um Deine Tabelle neu anzulegen kopiere den Code in das SQL-Fenster der Workbench bzw. von phpmyadmin. Natürlich geht das auch in einem Terminal.

Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.

ursus contionabundo
  • Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.
  • Also, liebewinter. [Das Skript funktioniert](https://forum.selfhtml.org/self/2019/may/11/phpmyadmin-nicht-start/1748683#m1748683), das habe ich getestet. Natürlich musst Du Deine Zugangsdaten eintragen.
  • Vielleicht ist Deine Datentabelle "mela" anders als meine:
  • ~~~sql
  • DROP TABLE IF EXISTS `mela`;
  • CREATE TABLE `mela` (
  • `name` tinytext,
  • `email` tinytext,
  • `message` text,
  • `datetime` datetime DEFAULT NULL,
  • `ip` tinytext,
  • KEY `datetime` (`datetime`),
  • FULLTEXT KEY `message` (`message`)
  • FULLTEXT KEY `name` (`name`),
  • FULLTEXT KEY `email` (`email`),
  • FULLTEXT KEY `message` (`message`),
  • FULLTEXT KEY `ip` (`ip`)
  • ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;
  • ~~~
  • Immerhin war ja bei Dir die IP ein Integer, also eine Zahl - was FALSCH ist.

Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.

ursus contionabundo
  • Deine Tabelle ist wahrscheinlich (noch) falsch.
  • Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.
  • Also, liebewinter. [Das Skript funktioniert](https://forum.selfhtml.org/self/2019/may/11/phpmyadmin-nicht-start/1748683#m1748683), das habe ich getestet.
  • Also, liebewinter. [Das Skript funktioniert](https://forum.selfhtml.org/self/2019/may/11/phpmyadmin-nicht-start/1748683#m1748683), das habe ich getestet. Natürlich musst Du Deine Zugangsdaten eintragen.
  • Vielleicht ist Deine Datentabelle "mela" anders als meine:
  • ~~~sql
  • DROP TABLE IF EXISTS `mela`;
  • CREATE TABLE `mela` (
  • `name` tinytext,
  • `email` tinytext,
  • `message` text,
  • `datetime` datetime DEFAULT NULL,
  • `ip` tinytext,
  • KEY `datetime` (`datetime`),
  • FULLTEXT KEY `message` (`message`)
  • ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;
  • ~~~
  • Immerhin war ja bei Dir die IP ein Integer - was falsch ist.
  • Immerhin war ja bei Dir die IP ein Integer, also eine Zahl - was FALSCH ist.

Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.

ursus contionabundo
  • Deine Tabelle ist wahrscheinlich (noch) falsch.
  • Also, liebewinter. [Das Skript funktioniert](https://forum.selfhtml.org/self/2019/may/11/phpmyadmin-nicht-start/1748683#m1748683), das habe ich getestet.
  • Vielleicht ist Deine Datentabelle "mela" anders als meine:
  • ~~~sql
  • DROP TABLE IF EXISTS `mela`;
  • CREATE TABLE `mela` (
  • `name` tinytext,
  • `email` tinytext,
  • `message` text,
  • `datetime` datetime DEFAULT NULL,
  • `ip` tinytext,
  • KEY `datteime` (`datetime`),
  • KEY `datetime` (`datetime`),
  • FULLTEXT KEY `message` (`message`)
  • ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;
  • ~~~
  • Immerhin war ja bei Dir die IP ein Integer - was falsch ist.

Deine Datenbank-Tabelle ist wahrscheinlich (noch) falsch.

ursus contionabundo
  • Es lag definitiv am PHP...
  • Deine Tabelle ist wahrscheinlich (noch) falsch.
  • Also, liebewinter. Das Skript funktioniert, das habe ich getestet.
  • Also, liebewinter. [Das Skript funktioniert](https://forum.selfhtml.org/self/2019/may/11/phpmyadmin-nicht-start/1748683#m1748683), das habe ich getestet.
  • Vielleicht ist Deine Datentabelle "mela" anders als meine:
  • ~~~sql
  • DROP TABLE IF EXISTS `mela`;
  • CREATE TABLE `mela` (
  • `name` tinytext,
  • `email` tinytext,
  • `message` text,
  • `datetime` datetime DEFAULT NULL,
  • `ip` tinytext,
  • KEY `datteime` (`datetime`),
  • FULLTEXT KEY `message` (`message`)
  • ) ENGINE=InnoDB DEFAULT CHARSET=utf8mb4;
  • ~~~
  • Immerhin war ja bei Dir die IP ein Integer - was falsch ist.