EddieGP: Veraltete Wiki-Software

problematische Seite

Hallo zusammen, auf dieser Spezialseite im Wiki kann eingesehen werden, mit welchen Software-Versionen das Wiki aktuell läuft. Dabei handelt es sich (C&P von dort) um:

Software Version
MediaWiki 1.19.24
PHP 5.3.3 (cgi-fcgi)
MySQL 5.1.73

PHP 5.3.3 wurde veröffentlicht im Juli 2010 und Sicherheitsupdates für den 5.3.x-Branch (dessen letzte Version im Übrigen 5.3.29 war) werden seit etwa 2,5 Jahren nicht mehr gepflegt. Für den gesamten 5.x.x-Branch wurde der aktive Support im Januar eingestellt, Sicherheitsupdates gibt es dafür noch etwa 1,5 Jahre lang. Insofern wäre die Planung eines Umstieges auf PHP7.x sicherlich angebracht.

Ähnlich verhält es sich mit MediaWiki, der gesamte 1.19-Zweig erhält seit Mai 2015 keinen Support mehr. Die aktuelle Version ist 1.28, wobei auch die LTS-Version 1.27 noch regelmäßig mit Sicherheitsupdates versorgt wird (zum Beispiel morgen). Um genau zu sein gibt es noch eine dritte, ältere Version, nämlich LTS 1.23. Im Sinne der LTS-Versionen wäre dies die Nachfolgeversion von 1.19. Ein Update auf diese Version ist aber eher nicht mehr zu empfehlen, denn sie wird inzwischen selbst von 1.27 abgelöst und erreicht im Mai ihr EOL.

Dass die fehlende Aktualisierung auf PHP 5.3.29 5.4.0 5.4.45 5.5.0 5.5.38 5.6.0 5.6.30 und MediaWiki 1.23.0 1.23.16 1.27.0 LTS 1.27.1 LTS für die Sicherheit eher unvorteilhaft (um es zurückhaltend zu formulieren) ist, brauche ich wohl nicht gesondert erläutern.

Zu beachten ist, dass MediaWiki nicht auf die aktuelle LTS-Version geupdated werden kann, ohne dass vorher PHP aktualisiert wird, da die Version 1.26 die letzte war, die PHP 5.3.3 unterstützte, seit MediaWiki 1.27 wird PHP 5.5.9 vorausgesetzt.

TL;DR: Es scheint so, dass das Wiki momentan mit einer seit 2 Jahre veralteten Wikisoftware auf einem Server mit einer seit 2,5 Jahren veralteten PHP-Version läuft. Nun stellt sich natürlich die Frage, ob sich jemand dieses Problemes bewusst sind und ob/wann/wie Aktualisierungen geplant sind.

Gruß EddieGP

Akzeptierte Antworten zum Thema:

  1. problematische Seite

    Hallo EddieGP,

    Nun stellt sich natürlich die Frage, ob sich jemand dieses Problemes bewusst sind und ob/wann/wie Aktualisierungen geplant sind.

    Das Problem ist uns bewusst, Aktualisierungen sind noch in diesem Frühjahr geplant.

    Bis demnächst
    Matthias

    -- Rosen sind rot.
    1. problematische Seite

      Hey,

      Das Problem ist uns bewusst, Aktualisierungen sind noch in diesem Frühjahr geplant.

      Vielen Dank für die schnelle Antwort! Dann ist mein Beitrag ja fast unnötig. ;)

      Kann/muss ich diesen Beitrag hier irgendwo als "gelöst" oder Ähnliches markieren, oder reicht das Akzeptieren der Antwort aus?

      Gruß, Eddie

      Edit: Ich sehe gerade, es gibt hier den gelöst-Tag. Dann wird sich das damit wohl erledigt haben.

      1. problematische Seite

        Tach!

        Kann/muss ich diesen Beitrag hier irgendwo als "gelöst" oder Ähnliches markieren, oder reicht das Akzeptieren der Antwort aus?

        Du kannst das machen und damit ein paar Punkte verteilen, aber eigentlich ist das auch egal.

        dedlfix.

        1. problematische Seite

          Hallo dedlfix,

          Kann/muss ich diesen Beitrag hier irgendwo als "gelöst" oder Ähnliches markieren, oder reicht das Akzeptieren der Antwort aus?

          Du kannst das machen und damit ein paar Punkte verteilen, aber eigentlich ist das auch egal.

          Nein. Als „akzeptiert” markierte Antworten werden in den Suchergebnissen signifikant besser gerankt. Es ist also ganz und gar nicht egal.

          LG,
          CK

          -- https://wwwtech.de/about
          1. problematische Seite

            Tach!

            Nein. Als „akzeptiert” markierte Antworten werden in den Suchergebnissen signifikant besser gerankt. Es ist also ganz und gar nicht egal.

            Generell ja, aber für diesen Threads ist es nicht wichtig, dass er irgendwo im Suchergebnis auftaucht.

            dedlfix.

  2. problematische Seite

    Tach!

    PHP 5.3.3 wurde veröffentlicht im Juli 2010 und Sicherheitsupdates für den 5.3.x-Branch (dessen letzte Version im Übrigen 5.3.29 war) werden seit etwa 2,5 Jahren nicht mehr gepflegt.

    Wenn man Server-Software einsetzt, die nach der Philosophie "alt aber stabil" vom Ersteller zusammengestellt ist, dann hat man da seit Beginn nicht das neueste Zeug drin und es wird in der Version auch nicht nachgereicht. Das ist bei Red Hat Enterprise und dessen Ableger CentOS der Fall. Was man aber hat, ist, dass der Hersteller auch Patches in diese alte Versionen portiert, die vom eigentlichen Hersteller der Software nicht mehr gepflegt werden. Zumindest war das eine Zeit lang so. Aus diesem Support dürfte die Version mittlerweile auch rausgealtert sein.

    dedlfix.

    1. problematische Seite

      Moin,

      Wenn man Server-Software einsetzt, die nach der Philosophie "alt aber stabil" vom Ersteller zusammengestellt ist, dann hat man da seit Beginn nicht das neueste Zeug drin und es wird in der Version auch nicht nachgereicht.

      Das ist ja auch gut so. "Das neuste Zeug" bringt schließlich auch gerne mal Fehler mit sich.

      Das ist bei Red Hat Enterprise und dessen Ableger CentOS der Fall.

      Rein interessehalber: War das jetzt ein beliebiges Beispiel oder ein Bezug auf die Software, die das Wiki verwendet?

      Was man aber hat, ist, dass der Hersteller auch Patches in diese alte Versionen portiert, die vom eigentlichen Hersteller der Software nicht mehr gepflegt werden. Zumindest war das eine Zeit lang so.

      Darauf hinzuweisen, dass diese "Zeit lang" vermutlich vorbei ist, das war meine Intention. Die 2,5 Jahre sollten nicht heißen, dass das was auf dem Server läuft definitiv schon seit 2,5 Jahren veraltet ist - sondern dass, unabhängig davon, wie andere Ersteller Patches portieren, diese Version sehr wahrscheinlich überholt ist, wenn PHP nicht erst vor ein paar Wochen/Monaten den Support dafür eingestellt hat, sondern schon vor mehr als zwei Jahren. Aber das scheint ja auch verständlich gewesen zu sein

      Aus diesem Support dürfte die Version mittlerweile auch rausgealtert sein.

      Gruß, Eddie

      1. problematische Seite

        Tach!

        Das ist bei Red Hat Enterprise und dessen Ableger CentOS der Fall.

        Rein interessehalber: War das jetzt ein beliebiges Beispiel oder ein Bezug auf die Software, die das Wiki verwendet?

        Sowohl als auch. Auch andere Distributionen gehen konservativ vor.

        dedlfix.

  3. problematische Seite

    Tach!

    auf dieser Spezialseite im Wiki kann eingesehen werden, mit welchen Software-Versionen das Wiki aktuell läuft. Dabei handelt es sich (C&P von dort) um:

    Software Version
    MediaWiki 1.19.24
    PHP 5.3.3 (cgi-fcgi)
    MySQL 5.1.73
    Software Version
    MediaWiki 1.27.3
    PHP 7.0.19 (fpm-fcgi)
    MariaDB 5.5.52-MariaDB

    Ist es jetzt besser?

    dedlfix.

    1. problematische Seite

      Servus!

      Ist es jetzt besser?

      Die Beispiele und das Frickl gehen nicht, aber das ist wohl nur ein Zwischenstand, oder?

      Exception encountered, of type "Error" [WRiWt-0ngTw86@sP-QlgNgAAAA0] /extensions/Selfhtml/example.php/Beispiel:HTML_button-Element-submit.html Error from line 40 of /var/www/mediawiki127/extensions.local/Selfhtml-2.3/example.php: Call to undefined method Article::getRawText() Backtrace: #1 {main}

      Herzliche Grüße

      Matthias Scharwies

      -- Es gibt viel zu tun: ToDo-Liste

      Folgende Nachrichten verweisen auf diesen Beitrag:

      1. problematische Seite

        Hallo Matthias Scharwies,

        und es sind auch noch wieder einige kleinere CSS-Sachen. Obwohl ich dachte, damit fertig zu sein. Das Iconset wird zum Beispiel nicht richtig angezeigt. Das liegt lt. Entwicklertools aber daran, dass die Grafiken nicht geladen werden konnten.

        Bis demnächst
        Matthias

        -- Rosen sind rot.
        1. problematische Seite

          Tach!

          und es sind auch noch wieder einige kleinere CSS-Sachen. Obwohl ich dachte, damit fertig zu sein. Das Iconset wird zum Beispiel nicht richtig angezeigt. Das liegt lt. Entwicklertools aber daran, dass die Grafiken nicht geladen werden konnten.

          Da hatte ich vergessen, neben der Datenbank auch noch das Bilder-Verzeichnis zu kopieren. Wenn man sich nicht jeden Schritt notiert, den man im Testsystem gemacht hat, …

          dedlfix.

      2. problematische Seite

        Tach!

        Die Beispiele und das Frickl gehen nicht, aber das ist wohl nur ein Zwischenstand, oder?

        Naja, ich hatte das schon getestet, aber dabei wohl nur Beispiele erwischt, für die dieser Code-Zweig nicht aufgerufen wurde, in dem diese nicht mehr vorhandene Funktion aufgerufen wurde. Die haben da ganz schön umgestrickt, was das Schreiben von Extensions anbelangt, und ich muss die SELFHTML-Extension mal von Grund auf neu schreiben.

        dedlfix.

        1. problematische Seite

          Hallo dedlfix, @Matthias Apsel @Matthias Scharwies

          das Syntaxhighlighting ist im Wiki kaputt, beispielsweise hier. Ist das schon bekannt?

          Gruß
          Julius

          1. problematische Seite

            Hallo Julius,

            das Syntaxhighlighting ist im Wiki kaputt, beispielsweise hier. Ist das schon bekannt?

            Jetzt ja.

            @dedlfix:

            Es ist richtig kaputt.

            Jetzt:

            <div class="note-box-text note-box-example-code"> <div class="mw-highlight mw-content-ltr" dir="ltr"> <pre> var Eingabe = ""; var Zaehler = 1; </pre> </div> </div>

            Früher:

            <div class="note-box-text note-box-example-code"> <div class="mw-geshi mw-code mw-content-ltr" dir="ltr"> <div class="javascript source-javascript"> <pre class="de1">

            Ich würde mal sagen, geshi tut es nicht mehr.

            Bis demnächst
            Matthias

            -- Rosen sind rot.
            1. problematische Seite

              Tach!

              das Syntaxhighlighting ist im Wiki kaputt, beispielsweise hier. Ist das schon bekannt?

              Da fehlte eine Dateiberechtigung. Aber irgendwas anderes ist da auch noch komisch. Ich sehe die Hochlichtung nur im angemeldeten Zustand.

              Ich würde mal sagen, geshi tut es nicht mehr.

              Richtig, das ist abgelöst worden durch pygmentize, die Extension heißt aber noch mit GeSHi im Namen.

              dedlfix.

              1. problematische Seite

                Tach!

                das Syntaxhighlighting ist im Wiki kaputt, beispielsweise hier. Ist das schon bekannt?

                Da fehlte eine Dateiberechtigung. Aber irgendwas anderes ist da auch noch komisch. Ich sehe die Hochlichtung nur im angemeldeten Zustand.

                Es könnte sich vielleicht erledigt haben. Falls noch Seiten mit ohne Farbe auftauchen, beziehungsweise generell bei Fehlern der Art "eigentlich müsste es", kann man versuchen, ?action=purge an die URL zu hängen, und wenn das nicht hilft, einen Null-Edit ausführen: Seite bearbeiten und ohne eine Änderung speichern. Das erscheint dann auch nicht im Log, löst aber den internen Wikimechanismus aus.

                dedlfix.

                1. problematische Seite

                  Hallo dedlfix,

                  Es könnte sich vielleicht erledigt haben.

                  Sieht so aus.

                  Bis demnächst
                  Matthias

                  -- Rosen sind rot.
        2. problematische Seite

          Servus!

          @dedlfix

          Vielen Dank für das Update!

          Ich wollte gerade bei den Beispielen des HTML-Einstiegstutorials das lang-Attribut hinzufügen, leider gibt es beim Speichern:

          Exception encountered, of type "Error"

          BTW: Die Überschriften enthalten immer noch ein span, in dem sich die id befindet. Könnte man das nicht vereinfachen? Oder muss der wegen des Bearbeiten-Buttons so sein?

          <h2><span class="mw-headline" id="Bilder_und_wie_man_sie_in_HTML_einbindet">Bilder und wie man sie in HTML einbindet</span><span class="mw-editsection"><span class="mw-editsection-bracket">[</span><a href="/index.php?title=HTML/Tutorials/HTML-Einstieg/Kapitel7&amp;action=edit&amp;section=1" title="Abschnitt bearbeiten: Bilder und wie man sie in HTML einbindet">Bearbeiten</a><span class="mw-editsection-bracket">]</span></span></h2>

          Könnte man den Bearbeiten-Button nicht wie früher rechts positionieren?

          Herzliche Grüße

          Matthias Scharwies

          -- Es gibt viel zu tun: ToDo-Liste
          1. problematische Seite

            Tach!

            Ich wollte gerade bei den Beispielen des HTML-Einstiegstutorials das lang-Attribut hinzufügen, leider gibt es beim Speichern:

            Das gibts nicht mehr. Also den Fehler, das Speichern gibt es noch.

            BTW: Die Überschriften enthalten immer noch ein span, in dem sich die id befindet. Könnte man das nicht vereinfachen? Oder muss der wegen des Bearbeiten-Buttons so sein?

            Das wird von MediaWiki so fabriziert.

            dedlfix.

            1. problematische Seite

              Servus!

              leider gibt es beim Speichern [nen error]:

              Das gibts nicht mehr. Also den Fehler, das Speichern gibt es noch.

              Vielen Dank!

              BTW: Die Überschriften enthalten immer noch ein span, in dem sich die id befindet. Könnte man das nicht vereinfachen? Oder muss der wegen des Bearbeiten-Buttons so sein?

              Das wird von MediaWiki so fabriziert.

              Ist mir vorher noch nie aufgefallen! 😀

              dedlfix.

              Herzliche Grüße

              Matthias Scharwies

              -- Es gibt viel zu tun: ToDo-Liste
          2. problematische Seite

            Hallo Matthias Scharwies,

            Könnte man den Bearbeiten-Button nicht wie früher rechts positionieren?

            Bis demnächst
            Matthias

            -- Rosen sind rot.
            1. problematische Seite

              Servus!

              Hallo Matthias Scharwies,

              Könnte man den Bearbeiten-Button nicht wie früher rechts positionieren?

              Vielen Dank, ich war mir anfangs nicht sicher, wo er denn vorher gewesen ist; stieß aber immer wieder auf die rechte Seite zum Anklicken des Bearbeitungsmodus.

              Herzliche Grüße

              Matthias Scharwies

              -- Es gibt viel zu tun: ToDo-Liste
    2. problematische Seite

      Hallo dedlfix,

      Vor allem, das jetzt das Weiterleiten (bzw. URL-Änderung) funktioniert, wie man es von der Wikipedia her kennt, freut mich. Beispiel.

      Vielen Dank!

      Gruß
      Julius