Matthias: Apache 1.3.27 Warnung ... please recompile with -DEAPI

Hallo,

ich richte gerade eine WAMP Maschine mit SSL-Support ein.

Umgebung: W2K SP3, Apache 1.3.27, PHP 4.3.1, MySQL 3.23.55, OpenSSL 0.9.6h

Grundsätzlich läuft alles, aber beim restart des Apache erhalte ich folgende Fehlermeldung:

[warning] loaded DSO .../php4apache.dll uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI).

Was muss kompiliert werden? Gibt es entsprechend kompilierte Versionen ev. zum download?

In Punkto Betriebssystem bin ich leider auf W2K fetgelegt.

Ich habe diverse Anregungen im Web gefunden, allerdings alle bezogen auf Linux Umgebungen - deshalb wende ich mich nun an dieses Forum.

Vielen Dank für jeden Tipp.
Matthias

  1. Holladiewaldfee,

    Grundsätzlich läuft alles, aber beim restart des Apache erhalte ich folgende Fehlermeldung:

    [warning] loaded DSO .../php4apache.dll uses plain Apache 1.3 API, this module might crash under EAPI! (please recompile it with -DEAPI).

    Das ist das Problem mit den alten Apachen und SSL.
    Und nein, ich habe noch keine Windows-Version gesehn, die so kompiliert wäre.

    In Punkto Betriebssystem bin ich leider auf W2K fetgelegt.

    Blöd ;-) Nimm den 2er-Apache da geht das glaube ich besser

    Wenn's kein richtiger Server ist kannst Du die Fehlermeldung eh grob in den Wind schlagen ;-)

    Ciao,

     Harry

    --
      Hä? Was? Signatur?! Kann man das essen?
      Wirrwarr: sh:| fo:) ch:] rl:° br:& n4:° ie:% mo:) va:) de:[ zu:) fl:( ss:) ls:[ js:|

    1. Hallo Harry,

      ein paar Stunden später und ein paar graue Haare reicher habe ich die Sache nun mit dem Apache2 am Laufen - bisher ohne Fehler.

      Da es sich um einen echten Live-Server handelt, wäre mir eigentlich der alten Apache lieber gewesen - zwecks der Erfahrung damit. Aber wenn der neue besser ist, warum nicht; werd ich halt noch ein paar zusätzliche Test-Sessions veranstalten.

      Danke für Deine Mithilfe.
      Matthias

    2. Noch ein Nachtrag,

      Apache2 SSL und PHP4 (als Modul) macht irgend etwas, aber sicher nicht das, was es soll.

      Die Arbeit kann man sich sparen.

      Als nächstes werde ich wohl den IIS versuchen müssen..
      Matthias

      1. Nehme alles zurück! Noch ein wenig in den conf's "herumgefummelt" und nun funzt es - wie mir scheint auch richtig stabil - mit SSL und allem drum und dran; war gerade am verzweifeln...
        Mahlzeit!
        Matthias