Alex: ScrollBy funktioniert nicht!

Hallo,
etwas erscheint im iFrame, es soll automatisch dahin (exakt oder in die nähe) gescrollt werden, tuts aber nicht:

  
function scrollToMsgPosition()  
{  
  var y = 0;  
  var msgPosition = document.getElementById("div_anzeige").style.top;  
  alert(msgPosition);  
  
  if(window.pageYOffset)  
  {  
    y = top.window.pageYOffset;  
  }  
  else if(document.body && document.body.scrollTop)  
  {  
    y = top.document.body.scrollTop;  
  }  
  alert(y);  
  if(y > msgPosition) // nach oben scrollen  
  {  
    window.scrollBy(0, -500);  
    setTimeout("scrollToMsgPosition()", 10);  
  }  
  else if(y < msgPosition) // nach unten scrollen  
  {  
    document.scrollBy(0, 500);  
    setTimeout("scrollToMsgPosition()", 10);  
  }  
}  

die Ausgabe javascriptalert(y); ist immer 0. Wieso?
Wenn ich den Script in einer seperaten *.html Datei ausführe, dann klappt es, aber sobald ich es in einem iFrame packe, tut sich nix. Warum?

  1. Hallo Alex!

    Wenn ich den Script in einer seperaten *.html Datei ausführe, dann klappt es, aber sobald ich es in einem iFrame packe, tut sich nix. Warum?

    Da Du nicht alles gepostet hast, sagt mir meine GLaskugel etwas von Same Origin Policy.

    Schönen Gruß

    1. Da Du nicht alles gepostet hast, sagt mir meine GLaskugel etwas von Same Origin Policy.

      Die selbe Domain. Bekomme auch keine Fehlermeldung, Firebug ist still.
      Eine Meldung (Div) erscheint im iFrame, dann sollte es dorthin gescrollt werden ... der Script steht bereits da, was soll ich dir noch zeigen?

      1. Hallo!

        Die selbe Domain. Bekomme auch keine Fehlermeldung, Firebug ist still.
        Eine Meldung (Div) erscheint im iFrame, dann sollte es dorthin gescrollt werden ... der Script steht bereits da, was soll ich dir noch zeigen?

        Was tut das _top_ in  y = top.window.pageYOffset;?

        Vielleicht scroll dein einbettendes Document gar nicht? ;)

        Schönen Gruß

        Afra

        1. Was tut das _top_ in  y = top.window.pageYOffset;?

          Vielleicht scroll dein einbettendes Document gar nicht? ;)

          Das war "rumprobieren", klappt nicht, habe das Problem anders "fast" gelöst.
          Danke.