fieldhopper: Neu im Land

Moin zusammen,

bin neu und hab natürlich wie jeder Anfänger gleich ein Problem.

Aus meinem Mix aus htlm und php funktioniert der Ausdruck <button><a href="programm.php" style="text-decoration: none;" target="blank">Drucken</a></button> im Chrome und Opera wunderbar. Nur Firefox und Iexplorer zicken rum. Das programm.php wird ausgeführt aber nichts wird angezeigt. Auch kein neues Fenster wird geöffnet. Fehlt dort eine Einstellung ? Danke für eure Hilfe.

Tschoe bis bald!

-- Mit freundlichem Gruß ... der fieldhopper
  1. Moin,

    target="_blank" siehe hier

    Fred

    -- I � Unicode
  2. Hallo,

    <button><a href="programm.php" style="text-decoration: none;" target="blank">Drucken</a></button>

    da hast du auf einen Druckknopf einen Druckknopf gesetzt und hoffts, das der richtige auslöst. Lass mal den button um den Link weg.

    Gruß
    Jürgen

    1. Hallo,

      Lass mal den button um den Link weg.

      das ist abhängig vom gewünschten Verhalten. Ich vermute, der Link sollte weg und den Button lassen.

      neue Seite → Link
      Aktion auf gleicher Seite → Button

      Gruß
      Kalk

      1. @@Tabellenkalk

        Ich vermute, der Link sollte weg und den Button lassen.

        href="programm.php" lässt mich anderes vermuten.

        neue Seite → Link

        oder auch andere Stelle auf der aktuellen Seite → Link

        Aktion auf gleicher Seite → Button

        Yep. Und das Ineinanderschachteln von Links und Buttons ist verboten.

        LLAP 🖖

        -- „Wer durch Wissen und Erfahrung der Klügere ist, der sollte nicht nachgeben. Und nicht aufgeben.“ —Kurt Weidemann
  3. hallo

    Moin zusammen,

    bin neu und hab natürlich wie jeder Anfänger gleich ein Problem.

    Aus meinem Mix aus htlm und php funktioniert der Ausdruck <button><a href="programm.php" style="text-decoration: none;" target="blank">Drucken</a></button> im Chrome und Opera wunderbar. Nur Firefox und Iexplorer zicken rum. Das programm.php wird ausgeführt aber nichts wird angezeigt. Auch kein neues Fenster wird geöffnet. Fehlt dort eine Einstellung ? Danke für eure Hilfe.

    Tschoe bis bald! --

    schreibe ins CSS

    button a[href]:after { content:"FAULTY HTML" !important; color:red !important; } -- Neu im Forum! Signaturen kann man ausblenden!