Gerhard1: Netzwerkproblem

Moin, ich habe zwei Windows-10-PC/Notebook. Jetzt wollte ich den wechselseitigen Zugriff definieren. Auf dem einen Rechner ist unter Netzwerk der andere Rechner zu sehen und ich kann die Verbindung (Netzwerklaufwerk verbinden) herstellen. Auf dem anderen Rechner ist kein Eintrag im Netzwerk. Wenn ich in dem Suchen-Dialog den anderen Rechner angebe, so kommt ein Fenster "Netzwerkanmeldeinformtionen eingeben", in dem der Benutzername und das Passwort angefordert werden. Ich kann mich aber nicht erinnern, jemals so etwas definiert zu haben. Woran mag das liegen? Versucht habe ich es mit den Anmeldeinformationen diese Rechners, erfolglos. Der Rechner, auf den ich zugreifen möchte, benötigt kein Kennwort beim Hochfahren. Gruß Gerhard

  1. Hallo Gerhard1,

    das könnte dir helfen.

    Falls dieser Link irgendwann nicht mehr zur Verfügung steht, hier noch mal die Essenz daraus:

    Erstellen der Heimnetzwerkes:

    Beide PC´s müssen eingeschaltet sein !

    Vorgehensweise am PC 1
    1. Systemsteuerung
    2. Netzwerk- und Freigabecenter
    3. Heimnetzgruppe
    4. Heimnetzgruppe erstellen
    5. Weiter
    6. Weiter
    7. Kennwort notieren , bzw. drucken

    Vorgehensweise am PC 2
    8. Systemsteuerung
    9. Netzwerk- und Freigabecenter
    10. Heimnetzgruppe
    11. Heimnetzgruppe jetzt beitreten
    12. Weiter
    13. Notiertes Kennwort eingeben
    14. Weiter
    15. Jetzt ist die Verbindung hergestellt!

    Achtung: Es ist nicht möglich Festplatten frei zu geben, sondern nur Ordner,
    1. diese durch anklicken mit der rechten Maustaste
    2. Freigabe für
    3. Heimnetzgruppe (anzeigen und bearbeiten)
    4. Bestimmte Person
    5. Hier: Selbst
    6. Freigabe
    7. Fertig

    Gruss
    Henry

    1. Hallo Henry,

      Heimnetzgruppe nicht mehr verwenden

      Danke Microsoft! NICHT!

      Rolf

      -- sumpsi - posui - clusi
      1. Ja, Heimnetzgruppe nicht mehr verwenden. Sie ist im übrigen gar nicht mehr sichtbar. Aber wie komme ich jetzt weiter bei meinem Problem?

        1. Hallo Gerhard1,

          achso, da war was 😂

          Du müsstest beide Computer in der gleichen Domäne oder in der gleichen Arbeitsgruppe haben, damit das funktioniert. Ich hab hier jetzt gerade nur einen Win7 Rechner, aber ich vermute, mit Win10 kommst Du auch weiter wenn Du Strg+Esc drückst und Computername ins Suchfeld eingibst. Da müsste dann irgendein Verweis in die Systemsteuerung kommen, um den Computernamen anzuzeigen. Da gibt's eine Möglichkeit, das zu ändern, und da kannst Du auch die Arbeitsgruppe setzen.

          Wenn Du nichts einstellst, lautet der Name der Arbeitsgruppe WORKGROUP. Was eigentlich doof ist, es bedeutet nämlich, dass zwei Computer, bei denen man an den Arbeitsgruppeneinstellungen nichts gemacht hat, automatisch in der gleichen Arbeitsgruppe sind.

          Die Details hab ich jetzt nicht mehr so drauf; im Büro haben wir Active Directory Domänen und zu Hause hab ich zuletzt in den Neunzigern was mit Arbeitsgruppen gemacht...

          Wenn Du die Computer FOO und BAR in der gleichen Arbeitsgruppe hast, und auf beiden Computern einen User Gerhard, dann sind das meines Wissens immer noch zwei verschiedene User. Windows verwendet eine Backslash-Notation, um einen User auf einem bestimmten Computer zu bezeichnen: FOO\Gerhard ist der User Gerhard auf dem Computer FOO. Gerhard@FOO könnte auch funktionieren. Möglicherweise gilt eine der Schreibweisen nur für Domains.

          Wenn FOO\Gerhard auf einen freigegebenen Ordner auf Computer BAR zugreifen will, muss die Freigabe nicht für Gerhard, sondern für FOO\Gerhard eingerichtet sein.

          Wenn Du von BAR aus den Rechner FOO suchst und auf dessen Netzwerkressourcen zugreifen willst, darf das natürlich nicht jeder. Selbst wenn sie in einer Arbeitsgruppe sind, ist der User BAR\Gerhard kein Admin auf FOO und hat darum kein Recht, den Computer zu inspizieren. Um das zu können, brauchst Du einen Benutzer mit Administratorrechten auf FOO. Das musst Du nicht einrichten, das ist automatisch so. Glaube ich jetzt jedenfalls.

          Du könntest auch noch schauen, ob einer der Computer als Netzwerkumgebung "öffentlich" eingestellt hat. In dem Fall ist der Zugang von außen aus Sicherheitsgründen beschränkt. Mit "privat" geht es besser, meine ich.

          Rolf

          -- sumpsi - posui - clusi
  2. Hi there,

    schon probiert, den Rechnern fixe IP-Adressen zu geben und dann über die Eingabeaufforderung zusammenzuhängen? Dagegen kann sich ein Windows10-Rechner eigentlich nicht wehren, wenn hardwartechnisch nichts kaputt ist, und diesen ganzen Gruppenquatsch brauchst Du auch nicht…

    1. Hallo klawischnigg, Du überschätzt meine Computerkenntnisse. Ich war der Meinung, dass ich keinen Einfluss auf die meinem Rechner vergebenen IP-Adresse habe. Sonst könnte ich doch meine Identität verschleiern - oder irre ich mich? Und wie ich Rechner über die Eingabeaufforderun zusammenhängen kann, weiß ich auch nicht

      1. Hallo Gerhard1,

        fixe IP-Adressen vergibst Du entweder im Router (dann erfolgt das per DHCP automatisch) oder in den Einstellungen des Netzwerkadapters im Computer (dann musst Du die vergeben Adresse aber im Router für DHCP sperren). Also - am Router musst Du auf jeden Fall 'ran, also mach es gleich da 😀. Verschleiern tust Du damit nichts, diese IP gelten nur in deinem internen Netz. Nach außen hin, jenseits des Routers, hast Du eine ganz andere IP, die vom Provider vergeben ist.

        Den Rest hab ich auch nicht verstanden. Eingabezeile, das klingt nach SSH. Mit Powershell geht sowas. Mit normalem CMD.EXE? Hmmm. Keine Ahnung.

        Rolf

        -- sumpsi - posui - clusi
        1. Hi there,

          cmd.exe reicht. Und dann der Befehl net use (laufwerksbuchstabe) \(ipadresse_des_anderen_rechners)(freigegebenes Verzeichnis) - also so etwas in der Art wie "net use m: \192.168.0.101\ORDNER"

          was der net-Befehl sonst noch kann erfährt man mit "net ?"

          Das funktioniert wenn's keinen Hardwarekonflikt oder ähnliches gibt eigentlich immer…

          1. Was ich noch sagen wollte - der Editor stahl mir den doppelten backslash, es muß:

            net use laufwerk: \\server-ip\ordner

            heissen!

          2. Hallo klawischnigg,

            ach so, NET USE :) Ich dachte du wolltest eine Remote Shell oder so angehen.

            Zumindest in einem Domänen-Netzwerk funktioniert der aber auch nur mit Username, also

            NET USE M: \\\\192.168.0.101\\FREIGABE /user:... *

            Als User muss man dabei eine Kombi computername\\username angeben (bzw. Domänenname\username in einem Domänen-Netzwerk). Das Sternchen ist wichtig, damit NET USE nach dem Passwort fragt.

            In einem Arbeitsgruppen-Netzwerk funktioniert das ohne Userangabe? Dann müsste man doch auch gleich mit UNC-Pfaden arbeiten können, also einfach \\192.168.0.101\FREIGABE im Adressfeld eines Explorerfensters eingeben.

            Zu beachten ist, dass da FREIGABE (also nicht "FREIGABE", sondern der Name einer Freigabe) steht und nicht ORDNER. NET USE und UNC-Pfade erfordern, dass auf dem Zielrechner ein Ordner freigegeben wurde (im Eigenschaften-Dialog des Ordners oder mit NET SHARE von der Befehlszeile). Der Name dieser Freigabe kann, muss aber nicht, der Ordnername sein. Dieser Freigabe werden dann Rechte zugewiesen. Es könnte funktionieren, hier dem eingebauten User "Jeder" (oder "Everyone" in englischem Windows) einfach volle Rechte zu geben, oder zumindest Lesen+Schreiben, um ohne explizite User-Angabe und weitere Rechteabfragen vom anderen Rechner aus zugreifen zu können.

            Rolf

            -- sumpsi - posui - clusi
            1. Hi there,

              Zumindest in einem Domänen-Netzwerk funktioniert der aber auch nur mit Username, also

              Naja, ich dachte, der OP will einfach zwei Rechner zusammenhängen. Von Domänennetzwerk ist das imho weit entfernt.

              NET USE M: \\\\192.168.0.101\\FREIGABE /user:... *

              Als User muss man dabei eine Kombi computername\\username angeben (bzw. Domänenname\username in einem Domänen-Netzwerk). Das Sternchen ist wichtig, damit NET USE nach dem Passwort fragt.

              Ja eh. Aber wie gesagt, siehe oben;) Ich würde das Problem halt so lösen, vielleicht aber ist das für den OP nicht applikabel. Wie gesagt, idR sollte das auch auf Windows10-Rechnern funktionieren, es sei denn, Hardwareproblem oder irgendeine Paranoia-Einstellung wie Passwörter oder ähnlicher Quatsch verhindern das.

              Zu beachten ist, dass da FREIGABE (also nicht "FREIGABE", sondern der Name einer Freigabe) steht und nicht ORDNER.

              Normalerweise ist halt die Freigabe irgendein Directory. Auf meinen XP-Rechnern hab ich immer die ganze Platte freigegeben, aber ich glaube gehört zu haben, daß das auf neueren Windows-Versionen so leicht nicht mehr geht.

  3. Hi Gerhard,

    es gibt da einen uralten Bug: Wenn Rechnernamen oder allg. Freigabenamen (Drucker usw.) einen Bindestrich enthalten, kann es unter Windowsrechnern zu solchen Problemen kommen.

    MfG

  4. Hallo Gerhard1,

    ich sehe da gerade:

    Der Rechner, auf den ich zugreifen möchte, benötigt kein Kennwort beim Hochfahren.

    Irrtum. Jedes Windows der NT-Linie hat eine Benutzerverwaltung. Aber man kann ihm sagen, dass bestimmter User automatisch und ohne Kennworteingabe angemeldet werden soll. Aber er muss ein Kennwort haben. Das musst Du für eine Anmeldung über Netzwerk kennen. Leere Kennwörter gibt's bei Win10 nicht.

    Rolf

    -- sumpsi - posui - clusi
    1. Hallo Rolf, in den Einstellungen/Anmeldeinformationen steht bei mir "Ihr Konto besitzt kein Kennwort" Ich weiß daher nicht, wo ich eines eingegeben habe und wie ich es ggf. herausfinden sollte Mein Konto: Lokales Konto, Administrator.

      1. Hallo Gerhard1,

        aha. Wieder was gelernt. Angeblich geht das nicht. Eigentlich ZWINGT Windows den Benutzer, bei der Einrichtung des PC ein Passwort zu vergeben. Windows 10, sagst Du⁉️

        Aber…

        Du arbeitest als Admin, ohne Kennwort? Dann vergib eins. Ein Computer ohne Passwort ist eine Katastrophe, die darauf wartet, zu passieren. Und leg einen weiteren Benutzer an, für die normale Arbeit, der kein Admin ist. Ständiges Arbeiten als Admin ist eine Katastrophe, die... etc 😕

        Um deine Arbeitsdateien, die Du als Admin angelegt hast, mit dem Normalnutzer bearbeiten zu können, musst Du sie aus dem Benutzerordner des Admin hinausverlegen.

        Wenn Du nicht willst - ok, deine Sache.

        Für den Zugriff vom einen Rechner zum anderen brauchst Du aber auf jeden Fall einen Benutzer, der ein Passwort hat. Wenn Du die große Nummer nicht spielen willst, leg einfach einen Lokalen Benutzer als Normalnutzer und mit Passwort an. Es kann sein, dass dann die automatische Anmeldung als Admin nicht mehr funktioniert. Das kann man in der Registry ändern. Beschreibung bei Microsoft.

        Rolf

        -- sumpsi - posui - clusi
        1. Hi, der andere Win-10-Rechner hat aber ebenfalls kein Passwort. Und wie ich eingangs geschrieben habe, funktioniert der Zugriff in der einen Richtung. Beide Rechner haben die neuesten Windows-10-Updates.