selfmade01: Probleme nach Neuinstallation Apache2 mit Scriptausführung (PHP Jquery)

Hallo habe hier ein plötzliches Problem mit einem apache2 und einem php/javascript(jquery) was ich mal vor einiger Zeit programmiert habe

beim Ausführen der Seite (die im Hintergrund auf eine DB zugreift (das geht noch) ) auf der ich dann einen Datensatz löschen/ändern möchte, bekomme ich seltsame Fehlermeldungen im Log

Das einzige was ich geändert habe ist

den Raspberry habe ich nun seit ca 3 Jahren nicht genutzt

die SD-Karte war dann defekt

ich habe alles aus einem backup auf eine neue SD-Karte installiert

ich habe keine .htaccess und keine großen Rechtevergaben da alles im lokalen System läuft

ich habe durchgehend 777 in allen Verzeichnissen unter /var/www/html

ich verwende zum Testen versch. virtuelle Server auf bestimmten Ports

unter allen virtuellen servern läuft eigentlich das gleich PHP-Programm... ich teste nur auf versch. servern versch. Dinge aus

was mich stutzig macht. Die PHP-Webseite funktioniert soweit genauso wie zuvor wenn ich jedoch Datensätze , anlegen, ändern oder löschen will was zuvor funktionierte dann geht das nun nicht mehr ( ich verwende hier meist jquery-scripte)

er zeigt mir auch in den Logs keine ausreichenden Fehlermeldungen die mich auf den Fehler führen würden wie "Seite nicht gefunden" etc...

was kann das sein?

Grüße Selfmade

Meine Version

PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)" NAME="Raspbian GNU/Linux" VERSION_ID="9" VERSION="9 (stretch)" ID=raspbian ID_LIKE=debian PHP Version 7.0.19-1 Apache/2.4.25 (Raspbian) [Sun Feb 17 02:40:16.509151 2019] [proxy_fcgi:error] [pid 7002:tid 2851075120] [client 192.168.2.22:26269] AH01071: Got error 'Primary script unknown\n', referer: http://192.168.2.10:8080/index.php [Sun Feb 17 02:40:18.026221 2019] [proxy_fcgi:error] [pid 7002:tid 3044013104] [client 192.168.2.22:26269] AH01071: Got error 'Primary script unknown\n', referer: http://192.168.2.10:8080/index.php [Sun Feb 17 02:40:20.492468 2019] [proxy_fcgi:error] [pid 7002:tid 3027235888] [client 192.168.2.22:26269] AH01071: Got error 'PHP message: PH P Warning: Creating default object from empty value in /var/www/html/grobot.myhome_8080.de/incl/getData/getGridDataHardwareInfo.php on line 6 0\n', referer: http://192.168.2.10:8080/index.php [Sun Feb 17 02:40:28.142285 2019] [proxy_fcgi:error] [pid 7003:tid 2859463728] [client 192.168.2.22:26306] AH01071: Got error 'Primary script unknown\n', referer: http://192.168.2.10:8080/index.php [Sun Feb 17 02:40:20.492468 2019] [proxy_fcgi:error] [pid 7002:tid 3027235888] [client 192.168.2.22:26269] AH01071: Got error 'PHP message: PH P Warning: Creating default object from empty value in /var/www/html/grobot.myhome_8080.de/incl/getData/getGridDataHardwareInfo.php on line 6 0\n', referer: http://192.168.2.10:8080/index.php
  1. Ein bischen sehr verworren Deine Problembeschreibung. Beschreib doch mal Deine Konfiguration, offensichtlich sind da mehrere virtuelle Server im Spiel. Lief das vorher auch schon unter FastCGI?

    Creating default object from empty value in /var/www/html/grobot.myhome_8080.de/incl/getData/getGridDataHardwareInfo.php on line 6

    Wäre zu prüfen.

    Primary script unknown\n

    Das auch. MFG

    1. Hallo,

      ob der Server zuvor auch unter FastCGI lief, weiß ich leider nicht.

      kann es an dem liegen? wenn ja wie kann ich es aus meiner Konfiguratiuon entfernen?

      das getGridDataHardwareInfo.php überprüfe ich

      das Primary script unknown\n sagt mir gar nichts... ich weiß hier nicht mal was es bedeutet und wonach ich suchen sollte

      und ja, es laufen mehrere virtuelle Server in deren apache config Datei hat jeder Server sein eigens LOG Grüße Jürgen

      1. Hi nochmal,

        es kann an Allem liegen 😉 Hast Du evntl. Cross Site Requests (angesichts mehrerer virtueller Server)?

        FastCGI: Im Prinzip läuft da ein Script zwischen Webserver und Deiner Anwendung. Sozusagen ein Proxy. Und das ist mit Sicherheit beim Apache konfiguriert. Diesen Proxy findest Du, falls konfiguriert, auch in der Prozessliste.

        MfG

        1. Hallo Cross Site Requests sorry keine Ahnung was das ist... ich habe hier eine Standard-Installation und darunter habe ich ein paar virtuelle server konfiguriert damit ich best. seiten testen kann.

          Kannst du mir bitte anhand einiger steps erklären wo ich wie was suchen muss

          das sind meine Prozesse die laufen

          1 ? 00:00:56 systemd 2 ? 00:00:00 kthreadd 3 ? 00:00:11 ksoftirqd/0 5 ? 00:00:00 kworker/0:0H 7 ? 00:00:00 lru-add-drain 8 ? 00:00:00 kdevtmpfs 9 ? 00:00:00 netns 10 ? 00:00:00 khungtaskd 11 ? 00:00:00 oom_reaper 12 ? 00:00:00 writeback 13 ? 00:00:00 kcompactd0 14 ? 00:00:00 crypto 15 ? 00:00:00 bioset 16 ? 00:00:00 kblockd 17 ? 00:00:00 watchdogd 19 ? 00:00:00 rpciod 20 ? 00:00:00 xprtiod 21 ? 00:00:00 kswapd0 22 ? 00:00:00 nfsiod 32 ? 00:00:00 kthrotld 33 ? 00:00:00 bioset 34 ? 00:00:00 bioset 35 ? 00:00:00 bioset 36 ? 00:00:00 bioset 37 ? 00:00:00 bioset 38 ? 00:00:00 bioset 39 ? 00:00:00 bioset 40 ? 00:00:00 bioset 41 ? 00:00:00 bioset 42 ? 00:00:00 bioset 43 ? 00:00:00 bioset 44 ? 00:00:00 bioset 45 ? 00:00:00 bioset 46 ? 00:00:00 bioset 47 ? 00:00:00 bioset 48 ? 00:00:00 bioset 49 ? 00:00:00 bioset 50 ? 00:00:00 bioset 51 ? 00:00:00 bioset 52 ? 00:00:00 bioset 53 ? 00:00:00 bioset 54 ? 00:00:00 bioset 55 ? 00:00:00 bioset 56 ? 00:00:00 bioset 57 ? 00:00:00 iscsi_eh 58 ? 00:00:00 dwc_otg 59 ? 00:00:00 DWC Notificatio 60 ? 00:00:00 VCHIQ-0 61 ? 00:00:00 VCHIQr-0 62 ? 00:00:00 VCHIQs-0 63 ? 00:00:00 VCHIQka-0 64 ? 00:00:00 SMIO 67 ? 00:00:00 bioset 68 ? 00:00:04 mmcqd/0 69 ? 00:00:00 jbd2/mmcblk0p2- 70 ? 00:00:00 ext4-rsv-conver 71 ? 00:00:00 ipv6_addrconf 91 ? 00:00:00 kworker/0:1H 114 ? 00:00:06 systemd-journal 124 ? 00:00:01 systemd-udevd 205 ? 00:00:01 systemd-timesyn 231 ? 00:00:42 dbus-daemon 236 ? 00:00:17 systemd-logind 240 ? 00:00:02 avahi-daemon 243 ? 00:00:00 rsyslogd 245 ? 00:00:00 cron 247 ? 00:00:02 thd 248 ? 00:00:00 avahi-daemon 256 ? 00:00:00 cfg80211 371 ? 00:00:04 dhcpcd 382 ? 00:00:00 xrdp-sesman 386 ? 00:00:23 php-fpm7.0 401 ? 00:00:00 sshd 430 ? 00:00:00 agetty 431 ? 00:00:00 xrdp 432 tty1 00:00:00 agetty 533 ? 00:00:02 php-fpm7.0 534 ? 00:00:02 php-fpm7.0 584 ? 00:05:36 mysqld 1307 ? 00:00:01 kworker/u2:1 2819 ? 00:00:04 proftpd 3503 ? 00:00:00 kworker/u2:2 8259 ? 00:00:00 sshd 8264 ? 00:00:00 systemd 8267 ? 00:00:00 (sd-pam) 8274 ? 00:00:02 sshd 8778 ? 00:00:00 kworker/0:2 9088 ? 00:00:00 kworker/0:3 9093 ? 00:00:00 apache2 9097 ? 00:00:00 apache2 9098 ? 00:00:00 apache2
          1. php-fpm7.0 PHP FastCGI Process Manager

            CSR: Wenn z.B. mit Ajax (JQuery) eine Seite die unter 192.168.1.1 ausgeliefert wurde einen Request nach 192.168.1.3 sendet.

            Fehlersuche und Fehlerbehandlung fängt aber auch nicht erst im Serverlog an. MfG

            1. php-fpm7.0 PHP FastCGI Process Manager

              CSR: Wenn z.B. mit Ajax (JQuery) eine Seite die unter 192.168.1.1 ausgeliefert wurde einen Request nach 192.168.1.3 sendet.

              oder zu: grobot.myhome oder zu: 192.168.1.12:8080 (anderer Port)

              Fehlersuche und Fehlerbehandlung fängt aber auch nicht erst im Serverlog an.

              Naja. @selfmade01 : Spuckt den Apache womöglich schon bei einem Restart Fehler aus?

              1. Bei der Problembeschreibung müssen wir wohl auch das Problem ersteinmal suchen. MFG

    1. https://serverfault.com/questions/847312/rewriting-urls-while-using-mod-proxy-fcgi-and-path-info-ends-up-with-error-404/847750#847750

      In mod_rewrite it es schon fragwürdig, SCRIPT_FILENAME zu verwenden. Aber wer weiß welche Variablen da noch geändert wurden, da sollte man sich mal die ganze Umgebung ausgeben lassen. MFG