Christian Kruse: Classic Forum 2.0 Release

Hallo z'sammen,

tja, endlich ist es soweit: die 2.0 Stable des Classic Forums wurde
released. Unter anderem gibt es jetzt sowas wie:

  • flt_scoring. Hiermit ist Newsreader-aehnliches Scoring moeglich,
      naehere Informationen dazu gibt es hier: /scoring.html
  • flt_link geht wieder. Ja, endlich ;-) Und es gibt einige Optionen,
      die das Verhalten beeinflussen.
  • flt_motd ist implementiert, die MOTD kann der Administrator
      festlegen.
  • Allgemein Bugfixes, sollte jetzt alles schoener, schneller und
      stabiler laufen ;-)

Grüße,
 CK

--
Ganz gleich, welchen Weg ich wähle, ich kehre heim.
http://wwwtech.de/

  1. Hi CK!

    Hallo z'sammen,

    tja, endlich ist es soweit: die 2.0 Stable des Classic Forums wurde
    released.

    Gab es deshalb eben einen 500er: Internal Sever Error?

    Grüße,
    Fabian St.

    --
    Endlich online: http://fabis-site.net
    --> XHTML, CSS, PHP-Formmailer, Linux

    Selfcode: ie:% fl:|  br:^ va:) ls:& fo:) rl:( n4:° ss:| de:> js:| ch:| mo:) zu:)

    1. Hallo Fabian,

      tja, endlich ist es soweit: die 2.0 Stable des Classic Forums
      wurde released.

      Gab es deshalb eben einen 500er: Internal Sever Error?

      Ja, ich musste erst die Konfigurations-Daten anpassen.

      Grüße,
       CK

      --
      Sobald dir ein Gedanke kommt, lache über ihn.
      http://wwwtech.de/

  2. hallo CK,

    tja, endlich ist es soweit: die 2.0 Stable des Classic Forums wurde released.

    Ach, das war eben der Server Error ;-)

    Unter anderem gibt es jetzt sowas wie

    Dankesehr.

    Grüße aus Berlin

    Christoph S.

    --
    mailto:christoph.schnauss@berlin.de
    http://www.christoph-schnauss.de

    ss:| zu:) ls:& fo:) va:) sh:| rl:|

  3. Hi,

    • flt_scoring. Hiermit ist Newsreader-aehnliches Scoring moeglich,
        naehere Informationen dazu gibt es hier: /scoring.html

    Klingt interessant.

    • flt_link geht wieder. Ja, endlich ;-) Und es gibt einige Optionen,
        die das Verhalten beeinflussen.

    Klingt unverständlich. Was bringt das mir als User?

    • flt_motd ist implementiert, die MOTD kann der Administrator
        festlegen.

    Klingt unverständlich. Was bringt das mir als User?

    • Allgemein Bugfixes, sollte jetzt alles schoener, schneller und
        stabiler laufen ;-)

    Klingt unverständlich. Was bringt das mir als User?

    War wegen des Updates vorhin das Forum nicht erreichbar?

    cu,
    Andreas

    Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

    -- MudGuard? Siehe http://www.Mud-Guard.de/
    1. Hi,

      • Allgemein Bugfixes, sollte jetzt alles schoener, schneller und
          stabiler laufen ;-)

      Klingt unverständlich. Was bringt das mir als User?

      Mist. Smiley vergessen ;-)

      cu,
      Andreas

      Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

      -- MudGuard? Siehe http://www.Mud-Guard.de/
      1. Hallo MudGuard,

        • Allgemein Bugfixes, sollte jetzt alles schoener, schneller
            und stabiler laufen ;-)

        Klingt unverständlich. Was bringt das mir als User?

        Mist. Smiley vergessen ;-)

        *gg*

        Grüße,
         CK

        --
        Unsere Vorstellungen von der Ewigkeit sind genauso nuetlich wie die Mutmassungen eines Kuehkens ueber die Aussenwelt bevor es die Eierschale aufbricht.
        http://wwwtech.de/

    2. Hallo MudGuard,

      • flt_link geht wieder. Ja, endlich ;-) Und es gibt einige
          Optionen, die das Verhalten beeinflussen.

      Klingt unverständlich. Was bringt das mir als User?

      Die <link>-Tags werden wieder gesetzt.

      • flt_motd ist implementiert, die MOTD kann der Administrator
          festlegen.

      Klingt unverständlich. Was bringt das mir als User?

      Nichts.

      • Allgemein Bugfixes, sollte jetzt alles schoener, schneller und
          stabiler laufen ;-)

      Klingt unverständlich. Was bringt das mir als User?

      Denk mal scharf nach.

      War wegen des Updates vorhin das Forum nicht erreichbar?

      Ja.

      Grüße,
       CK

      --
      Die Stärke des Geistes ist unendlich, die Muskelkraft dagegen ist begrenzt.
      http://wwwtech.de/

      1. Hallo,

        Klingt unverständlich. Was bringt das mir als User?

        Die <link>-Tags werden wieder gesetzt.

        Juhu!!! Das hat mir schon sehr gefehlt, wollte eigentlich schon heute früh mal nachfragen ob das nur bei mir so ist.

        Grüße
        Jeena Paradies

        Kinder schlagen zu Erziehungszwecken ist in Deutschland verboten!
        http://jeenaparadies.de/artikel/kinderschlagen/

        Jeenas Bannertauschportal; selbstgemacht ;-)
        http://jeenasbannerbude.de

        -- In der Schweiz auf Tour mit Jeena
        http://jeenaparadies.de/weblog/2004/august/schweiz/
        1. Hallo Jeena, Schnucki,

          Klingt unverständlich. Was bringt das mir als User?

          Die <link>-Tags werden wieder gesetzt.

          Juhu!!! Das hat mir schon sehr gefehlt, wollte eigentlich schon
          heute früh mal nachfragen ob das nur bei mir so ist.

          du weisst doch, ich tu was alles, um euch gluecklich zu machen ;-)

          Grüße,
           CK

          --
          If God had a beard, he'd be a UNIX programmer.
          http://wwwtech.de/

          1. Hallo,

            Hallo Jeena, Schnucki,

            :)

            du weisst doch, ich tu was alles, um euch gluecklich zu machen ;-)

            Deswegen lieben wir dich auch soooooo sehr :)

            Grüße
            Jeena Paradies

            Kinder schlagen zu Erziehungszwecken ist in Deutschland verboten!
            http://jeenaparadies.de/artikel/kinderschlagen/

            Jeenas Bannertauschportal; selbstgemacht ;-)
            http://jeenasbannerbude.de

            -- In der Schweiz auf Tour mit Jeena
            http://jeenaparadies.de/weblog/2004/august/schweiz/
            1. Hallo Jeena, Hasischatzi,

              du weisst doch, ich tu was alles, um euch gluecklich zu
              machen ;-)

              Deswegen lieben wir dich auch soooooo sehr :)

              Hach, da wird einem doch gleich warm ums Herz ;-)

              Grüße,
               CK

              --
              Der Geist ist alles. Du wirst, was du denkst.
              http://wwwtech.de/

          2. Schnuckelchen,

            du weisst doch, ich tu was alles, um euch gluecklich zu machen ;-)

            du bist wahrlich ein Freudenspender. Endlich fällt das lästige Klicken weg :-) Danke.

            Grüße,
             Roland

            --
            XHTML- und CSS-Sidebars:
            http://aktuell.de.selfhtml.org/extras/xhtml-css-sidebars.htm

  4. Hi,

    Beim Aufruf der Benutzer-Einstellungen *) http://forum.de.selfhtml.org/cgi-bin/user/fo_userconf:

    Software error:

    I/O warning : failed to load external entity "/var/www/selfhtml.org/de/forum/shared/config/modconf/modules.xml"

    *) Ich wollte nachschauen, obs jetzt neue Optionen gibt.

    cu,
    Andreas

    Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

    -- MudGuard? Siehe http://www.Mud-Guard.de/
    1. Hallo MudGuard,

      Beim Aufruf der Benutzer-Einstellungen *) http://forum.de.selfhtml.org/cgi-bin/user/fo_userconf:

      Software error:

      I/O warning : failed to load external entity "/var/www/selfhtml.org/de/forum/shared/config/modconf/modules.xml"

      Danke, hatte vergessen den Pfad anzupassen.

      Grüße,
       CK

      --
      [remote-signature:http://www.defunced.de/cgi-bin/signature.pl]
      http://wwwtech.de/

  5. Hallo,

    Unter anderem gibt es jetzt sowas wie:

    • flt_scoring. Hiermit ist Newsreader-aehnliches Scoring moeglich, naehere Informationen dazu gibt es hier: /scoring.html

    Ich bevorzuge, alle Beiträge zu sehen. Aber: Jedem sein Scoring. ;-)

    • flt_link geht wieder. Ja, endlich ;-) Und es gibt einige Optionen, die das Verhalten beeinflussen.

    Gibt's eigentlich ein Firefox-PlugIn, das sich um <link> kümmert?

    • flt_motd ist implementiert, die MOTD kann der Administrator festlegen.

    Äh... Hat das was mit MOderaToren zu tun?

    • Allgemein Bugfixes, sollte jetzt alles schoener, schneller und stabiler laufen ;-)

    Wir wollen hoffen. ;-)

    Gruß aus http://www.bonn.de/
    Sven

    Selfcode: ie:% fl:( br:^ va:} ls:[ fo:) rl:( n4:{ ss:| de:> js:| ch:? mo:} zu:)
    Selfcode entschlüsseln: http://peter.in-berlin.de/projekte/selfcode/
    Selfcode-Info: http://emmanuel.dammerer.at/selfcode.html

    Für alle Forum-Neulinge:
    1.http://de.selfhtml.org/
    2.http://suche.de.selfhtml.org/ -> http://forum.de.selfhtml.org/archiv/
    3.http://forum.de.selfhtml.org/faq/ -> http://forum.de.selfhtml.org/cgi-bin/fo_post

    -- Do it yourSELF 'cause SELFmade is bestmade.
    1. Hi,

      • flt_motd ist implementiert, die MOTD kann der Administrator festlegen.

      Äh... Hat das was mit MOderaToren zu tun?

      Ich tippe eher auf

      Message
      Of
      The
      Day

      cu,
      Andreas

      Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

      -- MudGuard? Siehe http://www.Mud-Guard.de/
      1. morgens,

        Ich tippe eher auf Message Of The Day

        Ich auch, aber ich sehe grad keins :-( Normalerweise ist das ja /etc/motd, bei GenToo scheint es da aber keine "default"-Vorgabe zu geben.

        Grüße aus Berlin

        Christoph S.

        --
        mailto:christoph.schnauss@berlin.de
        http://www.christoph-schnauss.de

        ss:| zu:) ls:& fo:) va:) sh:| rl:|

    2. Hallo Arx,

      Unter anderem gibt es jetzt sowas wie:

      • flt_scoring. Hiermit ist Newsreader-aehnliches Scoring
        moeglich, naehere Informationen dazu gibt es hier:
        /scoring.html

      Ich bevorzuge, alle Beiträge zu sehen. Aber: Jedem sein Scoring. ;-)

      Du _musst_ ja Beitraege nicht ausblenden lassen, lass es dann halt
      einfach frei :-) Du kannst auch nur die Farbe aendern lassen. Je
      mehr Kriterien zutreffen, desto roeter wird dann der Thread.

      • flt_link geht wieder. Ja, endlich ;-) Und es gibt einige
        Optionen, die das Verhalten beeinflussen.

      Gibt's eigentlich ein Firefox-PlugIn, das sich um <link> kümmert?

      Ja, gibt es. Kannst du auf der Extensions-Page runterladen.

      • flt_motd ist implementiert, die MOTD kann der Administrator festlegen.

      Äh... Hat das was mit MOderaToren zu tun?

      Nein, »Message of the day« heisst das :-) Das ist dafuer da,
      so Nachrichten wie das mit dem Treffen oben einzublenden. Bisher
      waren dazu Template-Anpassungen noetig, jetzt geht das auch ohne,
      nur, indem man die motd-File anpasst :-)

      Grüße,
       CK

      --
      No Shoes On Mat!
      http://wwwtech.de/

      1. Hallo,

        • flt_motd ist implementiert, die MOTD kann der Administrator festlegen.

        Äh... Hat das was mit MOderaToren zu tun?

        Nein, »Message of the day« heisst das :-) Das ist dafuer da,
        so Nachrichten wie das mit dem Treffen oben einzublenden. Bisher
        waren dazu Template-Anpassungen noetig, jetzt geht das auch ohne,
        nur, indem man die motd-File anpasst :-)

        Aja, danke für diese und die anderen Infos.

        Was ich noch vergessen hatte, zu fragen: Was ist mit flt_tipofteday? Noch nicht fertig oder Einbindung in Forumshauptdatei vergessen?

        Gruß aus http://www.bonn.de/
        Sven

        Selfcode: ie:% fl:( br:^ va:} ls:[ fo:) rl:( n4:{ ss:| de:> js:| ch:? mo:} zu:)
        Selfcode entschlüsseln: http://peter.in-berlin.de/projekte/selfcode/
        Selfcode-Info: http://emmanuel.dammerer.at/selfcode.html

        Für alle Forum-Neulinge:
        1.http://de.selfhtml.org/
        2.http://suche.de.selfhtml.org/ -> http://forum.de.selfhtml.org/archiv/
        3.http://forum.de.selfhtml.org/faq/ -> http://forum.de.selfhtml.org/cgi-bin/fo_post

        -- Do it yourSELF 'cause SELFmade is bestmade.
  6. Hi Christian,

    wollte mich nur mal kurz erkundigen, ob das nur mein Problem ist, oder ob du da gerade wieder was am rumfummeln in der Software bist ;-)

    Jedenfalls kann ich mich nicht über /my einloggen - alles was ich da zu sehen kriege ist eine weißte Seite mit dem Quellcode:
        <html><body></body></html>
    Etwas arg sparsame programmierung, was? ;-))

    Na ja, hoffe jedenfalls dass bald wieder klappt. Vermutlich ist das bei allen User so, oder? Es kommt ja noch nicht eimal die Benutzername&Passwort Abfrage.

    MfG, Dennis.

    1. Hallo Dennis,

      ich bin ja so froh, dass du das hier erwähntst, ich dachte nämlich auch schon, ich spinne und es hätte womöglich damit zu tun, dass ich meine E-Mail nicht bis zum 03.08. eingetragen habe oder die eingetragene dieselbe war wie die, unter der das Passwort ggf. neu zugesandt wird.

      Versuche, mich neu zu registrieren schlugen aber auch fehl. Im Unterschied zu dier hatte ich aber immer die Login-Eingabe-Abfrage, landete dann aber unter http://forum.de.selfhtml.org/my/ immer nur auf einer weißen Seite ohne jegliche Fehlermeldung.

      Gruß Gernot

      1. Hi!

        Also, bei mir funktioniert das ganze ohne Probleme. Ich habe mich heute bereits rund 4mal in /my eingeloggt.

        Grüße,
        Fabian St.

        --
        Endlich online: http://fabis-site.net
        --> XHTML, CSS, PHP-Formmailer, Linux

        Selfcode: ie:% fl:|  br:^ va:) ls:& fo:) rl:( n4:° ss:| de:> js:| ch:| mo:) zu:)

        1. Hello,

          Also, bei mir funktioniert das ganze ohne Probleme. Ich habe mich heute bereits rund 4mal in /my eingeloggt.

          me too

          Harzliche Grüße aus http://www.annerschbarrich.de

          Tom

          -- Fortschritt entsteht nur durch die Auseinandersetzung der Kreativen
          Nur selber lernen macht schlau
          1. Hi Gernot, Fabian und Tom,

            Also, bei mir funktioniert das ganze ohne Probleme. Ich habe mich heute bereits rund 4mal in /my eingeloggt.

            me too

            Hm, ich habe jetzt gerade noch mal meinen Browser komplett geschlossen und bin dann wieder auf http://forum.de.selfhtml.de/my gegangen.
            Dort kam eigentlich dann auch ganz normal die Passwortabfrage, wo ich mein Benutzername und Passwort eigegeben habe (wurde auch angenommen), aber dann kam wieder nur diese tolle weiße Seite. ;-)

            @CK:
            Was ist da los? Liegt es an uns oder an dir/dem Server? :-/

            MfG, Dennis

          2. Hallo Tom,

            me too

            me still neither  !!!

            Ich bekomme eine leere Seite auf /my

            Vielleicht liegt es an meinem uralten Windows98, das sich mit der neuen Forumsversion nicht verträgt. Ich würde das ja auch gerne dort melden, wo es hingehört. Nur weiß ich im Moment auch nicht, wo Fehlermeldungen hingehören und ob ich mich da einloggen könnte.

            Ich bin aber sicher, dass bald alles gut wird.

            Gruß Gernot

            1. Hi Gernot,

              Vielleicht liegt es an meinem uralten Windows98, das sich mit der neuen Forumsversion nicht verträgt.

              Daran liegt es sicherlich nicht. Ich verwende Windows XP Home Edition und Mozilla 1.8 alpha 1. Also nicht so durchaus alte Sachen ;-)
              Habe übrigends gerade noch mal geschaut ob es in anderen Browsern genaso ist, gleiches Ergebnis im IE 6.0, Opera 7.2, wie auch im Mozilla 1.7.

              Ich würde das ja auch gerne dort melden, wo es hingehört. Nur weiß ich im Moment auch nicht, wo Fehlermeldungen hingehören und ob ich mich da einloggen könnte.

              Wird normalerweise unter http://bugs.selfhtml.org gemeldet.

              Ich bin aber sicher, dass bald alles gut wird.

              Hoffentlich ;-)

              MfG, Dennis.

            2. Hallo!

              Vielleicht liegt es an meinem uralten Windows98, das sich mit der neuen Forumsversion nicht verträgt.

              Daran wird's nicht liegen, hab mich eben problemlos eingeloggt; und mein Rechner läuft auch nicht unter Win98...

              Gruß, Achim

          3. Also, bei mir funktioniert das ganze ohne Probleme. Ich habe mich heute bereits rund 4mal in /my eingeloggt.

            me too

            me three,
            Gunnar

            -- "(Der Student) kann sich so völlig dem hingeben, was er naiv für die Computerwissenschaft hält, also der bloßen Verfeinerung seiner Programmiertechniken, daß er sich auf diese Weise effektiv daran hindert, etwas wirklich Wesentliches zu studieren."
            (Joseph Weizenbaum in "Die Macht der Computer und die Ohnmacht der Vernunft")
    2. Hallo Dennis,

      wollte mich nur mal kurz erkundigen, ob das nur mein Problem ist,
      oder ob du da gerade wieder was am rumfummeln in der Software
      bist ;-)

      Nein, die Software hat sich an der Stelle nicht geaendert.

      Jedenfalls kann ich mich nicht über /my einloggen - alles was ich
      da zu sehen kriege ist eine weißte Seite mit dem Quellcode:
          <html><body></body></html>

      Aha, du kriegst also einfach keinen Content vom Server. Seltsam.
      Username? Vielleicht Cache-Probleme?

      Grüße,
       CK

      --
      If God had a beard, he'd be a UNIX programmer.
      http://wwwtech.de/

      1. Hallo Christian,

        bei mir funktioniert das mit dem /my auch immer noch nicht - nur komplett weiße seite ohne Fehlermeldung, habe den Cache gelöscht.

        Was ich mir nur denke, ist dass möglicherweise aufgrund der nicht oder nicht abweichend von der öffentlichen eingegebenen E-Mail-Adresse mein Account ganz gelöscht worden sein könnte.

        Ich kann mich aber auch nicht neu registriern, dann gibt es "Internal Server Error"

        Schönen Gruß

        Gernot

        1. Hallo Gernot,

          bei mir funktioniert das mit dem /my auch immer noch nicht - nur
          komplett weiße seite ohne Fehlermeldung, habe den Cache gelöscht.

          Du musst mir schon den User-Namen geben ;-)

          Was ich mir nur denke, ist dass möglicherweise aufgrund der nicht
          oder nicht abweichend von der öffentlichen eingegebenen
          E-Mail-Adresse mein Account ganz gelöscht worden sein könnte.

          Nein. Bisher nicht.

          Grüße,
           CK

          --
          Wenn der Schüler bereit ist, erscheint der Meister.
          http://wwwtech.de/

          1. Hallo Christian

            Mein Username ist "gernotback".

            Ich habe übrigens auch eine von meiner oben angegebenen abweichende E-Mail-Adresse ohne weiteres über das kleine Eingabeskript eintragen können (meinte zwar, die E-Mail hätte ich achon bei der Registrierung angegeben, aber doppelt gemoppelt hält besser!). Der Erfolg wurde mir dort bestätigt, also muss ich doch eingeloggt gewesen sein, ich gehe ja immer zuerst auf /my, logge mich ein, sehe dass es nicht funzt und mach dann das /my wieder weg, um ins Normal-Forum zu gehen.

            Gruß gernot

            1. Hallo Gernot,

              Mein Username ist "gernotback".

              Ui. Danke. Problem lokalisiert und gefixed :-)

              Grüße,
               CK

              --
              No Shoes On Mat!
              http://wwwtech.de/

              1. Hi Christian,

                Ui. Danke. Problem lokalisiert und gefixed :-)

                Hey, prima, bei mir klappts jetzt auch wieder.

                Und woran lag das jetzt? An uns oder am Server?

                MfG, Dennis.

                Zufällige Hinweise:
                ------------------------
                Sinnvolles Zitieren: Man zitiert nur Teilsaetze des Vorposters
                auf die man sich bezieht! Nicht einfach alles.

                -- Mein SelfCode: ie:{ fl:{ br:^ va:) ls:< fo:) rl:( n4:& ss:) de:> js:( ch:{ sh:( mo:} zu:|
                1. Hallo Dennis,

                  Und woran lag das jetzt? An uns oder am Server?

                  Hierran:

                  void gen_tpl_name(u_char buff[256],u_char *tpl) {
                    t_name_value *vn = cfg_get_first_value(&fo_default_conf,"TemplateMode");

                    if(vn) {
                      snprintf(buff,256,tpl,vn->values[0]);
                    }
                    else {
                      snprintf(buff,256,tpl,"");
                    }
                  }

                  Das war ein Ueberbleibsel in

                    http://vms.wwwtech.de/cgi-bin/viewcvs.cgi/svn/trunk/src/modules/flt_frameset.c?rev=201&view=auto

                  Die Funktion gibt es (in korrekter Form) in

                    http://vms.wwwtech.de/cgi-bin/viewcvs.cgi/svn/trunk/src/clientlib.c?rev=213&view=auto

                  schon. So hat dann die inkorrekte Version die korrekte
                  ueberschrieben, krkr.

                  Grüße,
                   CK

                  --
                  So, wie ein Teil ist, ist das Ganze.
                  http://wwwtech.de/

                  1. Hi Christian,

                    Hierran:

                    void gen_tpl_name(u_char buff[256],u_char *tpl) {
                      t_name_value *vn = cfg_get_first_value(&fo_default_conf,"TemplateMode");

                      if(vn) {
                        snprintf(buff,256,tpl,vn->values[0]);
                      }
                      else {
                        snprintf(buff,256,tpl,"");
                      }
                    }

                    Ähm.... auch wenn ich das jetzt nicht so ganz verstanden haben, trotzdem
                    danke für deine Mühe ;-)

                    MfG, Dennis.

                    Zufällige Hinweise:
                    ------------------------
                    Den Selfcode kann man sich brigends hier decoden lassen:
                    http://www.peter.in-berlin.de/projekte/selfcode/

                    -- Mein SelfCode: ie:{ fl:{ br:^ va:) ls:< fo:) rl:( n4:& ss:) de:> js:( ch:{ sh:( mo:} zu:|
                    1. Hallo Dennis,

                      [... Code ...]

                      Ähm.... auch wenn ich das jetzt nicht so ganz verstanden haben,
                      trotzdem danke für deine Mühe ;-)

                      Nunja, die Funktion setzt halt den Namen eines Templates zusammen.
                      Dummerweise war sie eben veraltet, weil ich das Modul (flt_frameset)
                      bei der Ueberarbeitung vergessen hatte.

                      Grüße,
                       CK

                      --
                      To define recursion, we must first define recursion.
                      http://wwwtech.de/

                      1. Hi,

                        Nunja, die Funktion setzt halt den Namen eines Templates zusammen.
                        Dummerweise war sie eben veraltet, weil ich das Modul (flt_frameset)
                        bei der Ueberarbeitung vergessen hatte.

                        Ah, das dürfte erklären, warum es nur für einige nicht geklappt hat - nämlich für die, die sich das Forum im Frameset anzeigen lassen.

                        cu,
                        Andreas

                        Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

                        -- MudGuard? Siehe http://www.Mud-Guard.de/
                        1. Hallo Andreas,

                          dass ich ein Framesliebhaber bin, ist ja sowieso bekannt!
                          Nur manchmal muss ich dafür büßen.
                          ;-)

                          Gruß Gernot

              2. Hallo Chistian,

                danke dass du für uns deine Freizeit an diesen beiden schönen Sommertagen opferst. Bei mir läuft jetzt wieder alles so komfortabel, wie ich es gewohnt war. Die neuen Features schaue ich mir dann später mal an.

                Gruß Gernot

  7. Hi,

    • flt_scoring. Hiermit ist Newsreader-aehnliches Scoring moeglich,
        naehere Informationen dazu gibt es hier: /scoring.html

    Hm. Hab ich jetzt mal ausprobiert.
    Mit folgenden Werten:

    Ab welchem Score: 0 (ich will nichts ausblenden)
    Farbe: #f70000  (weils der Vorschlag ist und ich erstmal sehen wollte, ob ich weiter dran rumspiele)
    Regeln:

    Score: 30
    Field: Category
    Regex: CSS

    Als Antwort auf den Versuch, das Formular abzuschicken, bekam ich:
    Software error:

    unknown type "" for directive "ScoringFilter" at /var/www/selfhtml.org/de/forum/cgi-bin/user/fo_userconf line 500.

    Ach ja, es wäre schön, wenn es einen Link auf die Anleitung auch dort gäbe, wo sie am ehesten gebraucht wird - bei den Einstellungen.

    cu,
    Andreas

    Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

    -- MudGuard? Siehe http://www.Mud-Guard.de/
    1. Hallo MudGuard,

      • flt_scoring. Hiermit ist Newsreader-aehnliches Scoring
          moeglich, naehere Informationen dazu gibt es hier:
          /scoring.html

      Hm. Hab ich jetzt mal ausprobiert.
      Mit folgenden Werten:

      Ab welchem Score: 0 (ich will nichts ausblenden)

      Dann lass es frei :-)

      Als Antwort auf den Versuch, das Formular abzuschicken, bekam ich:
      Software error:

      unknown type "" for directive "ScoringFilter" at
      /var/www/selfhtml.org/de/forum/cgi-bin/user/fo_userconf line 500.

      Aehm, ja, gefixed :-) Danke.

      Ach ja, es wäre schön, wenn es einen Link auf die Anleitung auch
      dort gäbe, wo sie am ehesten gebraucht wird - bei den
      Einstellungen.

      Eins nach dem anderen.

      Grüße,
       CK

      --
      Nur die Weisesten und die Dümmsten können sich nicht ändern.
      http://wwwtech.de/

      1. Hi,

        Als Antwort auf den Versuch, das Formular abzuschicken, bekam ich:
        Software error:
        unknown type "" for directive "ScoringFilter" at
        /var/www/selfhtml.org/de/forum/cgi-bin/user/fo_userconf line 500.

        Aehm, ja, gefixed :-) Danke.

        Gefixed und ersetzt durch

        Software error:

        unknown type "" for directive "ScoringStartColor" at /var/www/selfhtml.org/de/forum/cgi-bin/user/fo_userconf line 500.

        Also wenn ich keine Farbe und keinen Startwert angebe, bekomme ich die Einstellungen gespeichert.
        Ach ja, die Beschreibung paßt auch irgendwie nicht:
        Vorgeschlagen wird hier #F70000 (127 Rot).
        F7 = 247, nicht 127

        Folgende Regel hab ich gesetzt:
        Score: 30
        Field: Category
        Regex: CSS

        Also CSS sollte hervorgehoben werden.

        Wo müßte jetzt die Rotfärbung auftauchen?
        Ich seh nämlich nichts.
        Auch nachdem ich die Hervorhebung nach Kategorie für CSS ausgeschaltet habe.

        cu,
        Andreas

        Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

        -- MudGuard? Siehe http://www.Mud-Guard.de/
        1. Hallo MudGuard,

          Gefixed und ersetzt durch

          Software error:

          unknown type "" for directive "ScoringStartColor" at
          /var/www/selfhtml.org/de/forum/cgi-bin/user/fo_userconf line 500.

          Hmpf. Ok, jetzt gehts aber.

          Ach ja, die Beschreibung paßt auch irgendwie nicht:
          Vorgeschlagen wird hier #F70000 (127 Rot).
          F7 = 247, nicht 127

          Jepp, Dreher. 7F ist 127 :-)

          Folgende Regel hab ich gesetzt:
          Score: 30
          Field: Category
          Regex: CSS

          Also CSS sollte hervorgehoben werden.

          Wo müßte jetzt die Rotfärbung auftauchen?

          Das gesamte Posting muesste dann in 30 Rot erscheinen.

          Grüße,
           CK

          --
          Ich bewundere wirklich den Sinn der Bienen für kollektive Verantwortung. Obwohl sich einzelne Bienen hin und wieder bekämpfen, herrscht zwischen Ihnen grundsätzlich ein starkes Gefühl für Eintracht und Zusammenarbeit. Wir Menschen gelten als sehr viel weiter entwickelt, doch mitunter rangieren wir sogar hinter kleinen Insekten.
          http://wwwtech.de/

          1. Hi,

            Folgende Regel hab ich gesetzt:
            Score: 30
            Field: Category
            Regex: CSS

            Also CSS sollte hervorgehoben werden.
            Wo müßte jetzt die Rotfärbung auftauchen?

            Das gesamte Posting muesste dann in 30 Rot erscheinen.

            Hm. Irgendwas mach ich wohl falsch.

            Ich krieg nix rotes zu sehen. Auch nicht nach Abschalten der Standard-Schriftfarbe.

            Und wieso 30? Laut scoring.html wird doch die Basisfarbe dazuaddiert:
            "Rot-Anteil der neuen Farbe = Rot-Anteil der eingestellten Basis-Farbe + 20"

            cu,
            Andreas

            Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

            -- MudGuard? Siehe http://www.Mud-Guard.de/
            1. Hi,

              Hm. Irgendwas mach ich wohl falsch.

              Ich krieg nix rotes zu sehen. Auch nicht nach Abschalten der Standard-Schriftfarbe.

              Korrektur: die Klammern um die Kategorie sowie das Wörtchen "von" färbt sich jetzt.
              Bei Folgepostings auch der Kategoriename - es sei denn, dieser ist über das "Kategorien hervorheben"-Feature gefärbt.

              cu,
              Andreas

              Fachfragen per E-Mail halte ich für unverschämt und werde entsprechende E-Mails nicht beantworten. Für Fachfragen ist das Forum da.

              -- MudGuard? Siehe http://www.Mud-Guard.de/
            2. Hallo,

              Hm. Irgendwas mach ich wohl falsch.

              Ich krieg nix rotes zu sehen.

              Ich kriege bei
              Score: 30
              Field: Subject
              Regex: xhtml
              nur folgendes:
              <span style="color:${flt_scoring_color};">
              wenn ich das Farbe-Feld leer lasse.
              Wenn ich wie empfohlen #7F0000 eingebe, bekomme ich 500 mit:
              ... molily.conf: ScoringStartColor: Callback function returned not 0 or -1!
              config file error!
              (Error-Log)

              Wieso sehe ich eigentlich noch Postings, wenn ich unter » Alle Postings, die weniger Punkte als hier angegeben haben, werden ausgeblendet.« 10 (oder 100) eingebe? Ausgehend vom Basis-Score müsste ich nur die mit xhtml im Subject sehen (wenn ich das System richtig verstanden habe).
              Ein negativer Wert wäre hier auch nett (»-10 mag noch lesbar sein, alles kleiner -19, also Postings mit zwei Negativkriterien, nicht«).

              Mathias

              1. Es wäre zudem schön, wenn die RegExp automatisch case-insensitive wäre. Wenn ich z.B. einen Poster mit dem Namen »Cheatah« runterscoren will, muss ich »Regexp: Cheatah« eingeben, damit es klappt. »cheatah« funktioniert nicht. Ich könnte natürlich mit Perversitäten wie »(c|C)(h|H)(e|E)(a|A)(t|T)(a|A)(h|h)« anfangen, aber das muss doch nicht sein, denke ich...

                1. Hallo molily,

                  Es wäre zudem schön, wenn die RegExp automatisch case-insensitive
                  wäre. Wenn ich z.B. einen Poster mit dem Namen »Cheatah«
                  runterscoren will, muss ich »Regexp: Cheatah« eingeben, damit es
                  klappt. »cheatah« funktioniert nicht. Ich könnte natürlich mit
                  Perversitäten wie »(c|C)(h|H)(e|E)(a|A)(t|T)(a|A)(h|h)« anfangen,
                  aber das muss doch nicht sein, denke ich...

                  Ja, das hatte ich eigentlich vorgehabt, hatte es aber vergessen
                  einzubauen. Ist jetzt aber drin.

                  Grüße,
                   CK

                  --
                  Mit einem Windhauch kannst du das Feuer loeschen. Mit einem Windhauch kannst du das Feuer entfachen.
                  http://wwwtech.de/

                2. Welchen Sinn hat überhaupt die Möglichkeit des Herunterscorens bei den jetzigen Farbeinstellungen?
                  Normalerweise werden Postings in schwarz angezeigt. Kein Score (Score 0) entspricht also #000000. Bei einem Score darunter müsste das Posting *unscheinbarer* sein als normale schwarze Postings mit dem Basis-Score. Wenn ein Posting nun -10 gescoret wird, dann hat es jedoch immer noch #750000. Das heißt, ein Posting mit *weniger* Score als die normalen schwarzen Basis-Score-Postings ist optisch *auffälliger*, weil es sich durch die rote Färbung von den anderen (den mit Score 0 und #000000) abhebt. Und ein Posting mit *mehr* Score als die normalen schwarzen Basis-Score-Postings ist optisch deutlich von eben diesen zu unterscheiden, aber nur geringfügig von denen, deren Score unter dem Basis-Score liegt. Ich weiß nicht, ob das so sinnig ist. Was habe ich denn gewonnen, wenn ich ein Posting auf -127 herunterscore? Es ist so genauso auffällig wie Score-0-Postings. Und bei jedem Score darüber ist es auffälliger.
                  Vielleicht sollte man darüber nachdenken, ob diese Farbanzeige eine angemessene Visualisierung des Scores ist. Wenn man *nur* hochscoret, mag es sinnvoll sein, von 0 = #000000 auszugehen und den Score auf den Rotanteil zu addieren. Somit stechen Postings mit hohem Score mehr ins Auge als solche mit niedrigerem.
                  Wenn der Sinn der Scoring-Funktion vor allem das Hochscoren mit dem Ziel des Rotfärbens sowie das Herunterscoren mit dem Ziel des Ausblendens, aber nicht das Herunterscoren mit dem Ziel des Unscheinbarmachens ist, dann ist die jetzige Regelung natürlich zumindest in sich stimmig.

                  Mathias

                  1. Hallo molily,

                    Normalerweise werden Postings in schwarz angezeigt. Kein Score
                    (Score 0) entspricht also #000000.

                    Nein, das ist abhaengig von der Basis-Farbe. Ich hatte mir das so
                    gedacht:

                    • vergeben der Basis-Farbe
                    • negativ scored Postings werden weniger rot angezeigt
                    • positiv scored Postings werden mehr rot angezeigt

                    Grüße,
                     CK

                    --
                    So, wie ein Teil ist, ist das Ganze.
                    http://wwwtech.de/

                    1. Moin!

                      Nein, das ist abhaengig von der Basis-Farbe. Ich hatte mir das so
                      gedacht:

                      • vergeben der Basis-Farbe
                      • negativ scored Postings werden weniger rot angezeigt
                      • positiv scored Postings werden mehr rot angezeigt

                      Wieso glaubst du, dass Rot eine geeignete Farbe wäre? Sowas sollte komplett dem User freigestellt sein, indem:

                      1. Eine Farbe für "neutral" anzugeben ist.
                      2. Eine Farbe für "100% toll" anzugeben ist.
                      3. Eine Farbe für "100% mies" anzugeben ist.
                      4. Ein Wert für die Sättigung (welcher Score ist 100%) anzugeben ist.
                      5. Je nach Scoring irgendwann die Sättigungsgrenze erreicht ist, und basierend auf dem Score eine Mischfarbe zwischen "neutral" und "toll" für positive Scores und zwischen "neutral" und "mies" für negative Scores gewählt wird.

                      Dein "Rot-Hack" ist zwar eine naheliegende Möglichkeit für die programmtechnische Umsetzung, aber sie schränkt den Benutzer zu sehr ein. Vielleicht kollidiert DEINE Wahl von Rot ja mit seiner bisherigen Wahl der Farben.

                       - Sven Rautenberg

                      1. Hallo Sven,

                        ich habe Teile deiner Ideen fuer ziemlich gut gefunden und jetzt
                        eingebaut :-) Siehe Konfigurations-Einstellungen.

                        Grüße,
                         CK

                        --
                        Willst du die Freuden dieser Welt geniessen, so musst du auch ihr Leid erdulden.
                        http://wwwtech.de/

              2. Hallo molily,

                nur folgendes:
                <span style="color:${flt_scoring_color};">

                Hargharg, genau falsch herum, es haette {$flt_scoring_color} sein
                muessen -- gefixed.

                Wenn ich wie empfohlen #7F0000 eingebe, bekomme ich 500 mit:
                ... molily.conf: ScoringStartColor: Callback function returned not
                0 or -1!
                config file error!
                (Error-Log)

                Auch gefixed.

                Wieso sehe ich eigentlich noch Postings, wenn ich unter » Alle
                Postings, die weniger Punkte als hier angegeben haben, werden
                ausgeblendet.« 10 (oder 100) eingebe? Ausgehend vom Basis-Score
                müsste ich nur die mit xhtml im Subject sehen (wenn ich das System
                richtig verstanden habe).

                Bisher wurden nur Postings beruecksichtigt, die auch ueberhaupt
                gescored wurden. Alle Postings, die nicht gescored wurden, wurden
                ignoriert -- habe ich aber jetzt geaendert, das macht keinen Sinn,
                irgendwie.

                Ein negativer Wert wäre hier auch nett (»-10 mag noch lesbar sein,
                alles kleiner -19, also Postings mit zwei Negativkriterien,
                nicht«).

                Dito fixed.

                Grüße,
                 CK

                --
                Der Mund ist das Portal zum Unglück.
                http://wwwtech.de/

  8. da will ich auch mal wieder vorbeigucken, Passwort sowieso vergessen, aber: Account anlegen will nicht! Das Ding glaubt, ich sei zu doof, das Passwort 2mal einzugeben!

    1. Hallo Kai,

      da will ich auch mal wieder vorbeigucken, Passwort sowieso
      vergessen, aber: Account anlegen will nicht! Das Ding glaubt, ich
      sei zu doof, das Passwort 2mal einzugeben!

      Sollte behoben sein.

      Grüße,
       CK

      --
      Keine Schneeflocke faellt je auf die falsche Stelle.
      http://wwwtech.de/

  9. Sup!

    Ich hoffe, das Ding wird erst in der Version 2.0.28 eingesetzt, sonst ist es sicher viiieeel zu unstable für einen professionellen, produktiven Einsatz!

    *SCNR*

    Gruesse,

    Bio

    -- Man kann aus Ackergaeulen keine Rennpferde machen
    1. hi

      Ich hoffe, das Ding wird erst in der Version 2.0.28 eingesetzt, sonst ist es sicher viiieeel zu unstable für einen professionellen, produktiven Einsatz!

      rennst du noch mit Kernel 2.0 rum?

      Gruß Kai

    2. Hallo Bio,

      Ich hoffe, das Ding wird erst in der Version 2.0.28 eingesetzt,
      sonst ist es sicher viiieeel zu unstable für einen
      professionellen, produktiven Einsatz!

      Hier laeuft 2.0.1 + ein paar Patches ;-)

      Grüße,
       CK

      --
      Kommt ein Vektor zur Drogenberatung: "Hilfe, ich bin linear abhaengig!"
      http://wwwtech.de/