Henry: Kein Wlan mehr auf Notebook auch nicht mit Stick

Hallo,

seltsames Problem, noch nie gehabt. Auf meinem Notebook(Windows) stellte sich auf einmal Wlan ab. Genauer, wird zwar im Netzwerkmanager angezeigt aber listet keine Funknetzwerke mehr auf.

Fehleranalyse ergibt "keine Netzwerkkonnektivität". Na ja, was meinen die damit jetzt genau? Auf jeden Fall half alles Probieren nicht, so legte ich mal eine Live-CD um zu sehen ob es an Windows läge, aber dem ist wohl nicht so, auch bei de, CD-OS keine Change. Gut, nächster Versuch, dachte wenn ein Hardwaredefekt vorliegt, müsste ja ein externer Wlan-Stick helfen, aber nö auch das nicht, gleiche Ergebnis, bzw. lässt sich gar nicht aktivieren.

Jetzt sind die Fehlermöglichkeiten in der Theorie natürlich mannigfaltig, also hoffe ich hier auf Erfahrungswerte mit ähnlichem Problem. Hat die Jemand?

Gruss
Henry

-- Meine Meinung zu DSGVO & Co:
„Principiis obsta. Sero medicina parata, cum mala per longas convaluere moras.“
  1. Oh.

    1.) Hast Du es womöglich mit den Hardware-Hotkeys abgeschhaltet?

    2.) Ich habe hier Notebooks, die haben nicht nur die Hotkeys FN + F5 sondern außerdem einen richtigen kleinen Ausschalter. (Oft an der Front oder an der Seite). Den hab ich auch schon mal versehentlich beim Transport oder Einpacken erwischt...

    Während Du an den Schaltern fummelst schaue mit sudo tail -f /var/log/syslognach ob sich was tut.

    Falls es das, entgegen der starken Vermutung, welche aus Deiner Beschreibung fast zwingend folgt (plötzlich, OS-unabhängig, überlebt reboot), nicht sein sollte kann eine Fehlkonfiguration vorliegen. Dann wären folgende Ausgaben interessant:

    A) Hardware:

    • ~> lshw
    • ~> lspci

    B) Einstellungen:

    • ~> ip address show
    • ~> ip route show
    • ~> less /etc/network/interfaces
    • ~> less /etc/resolv.conf
    1. Hallo Regina,

      auf die Idee mit der Fn-Taste, einem physischen Ausschalter oder einem kaputten WLAN-Kabel1 war ich auch schon gekommen, aber angesichts der Tatsache, dass auch ein Stick versagt, erschien mir das als nicht zielführend.

      Deswegen würde ich auch in Richtung Konfiguration tendieren. Da scheint irgendwas im Netzwerkstack schräg, aber da ich von Linux so viel verstehe wie ein Nilpferd vom Stricken, habe ich dazu nichts gesagt...

      Rolf

      -- sumpsi - posui - clusi
      1. Du sagst die ganze Zeit ja Laptop? Kannst du den noch mit den Handy über dein Router ins Netzt ,oder andere Geräte die an Router angeklemmt sind ?

        Fals ja,könnte man den Pc auch zurückstellen. Das hat mir auch schon oft geholfen .Jenachdem wie du das mal eingestellt hast kannst du den ja von wennige Tage bis hin zu Monaten zurück stellen.Eigene Daten bleiben soweit erhalten.

  2. Hallo,

    das Problem hat sich lösen lassen, weiß zwar nicht genau was die Ursache war aber dennoch mal hier die Vorgehensweise für ähnliche Fälle:

    Gerätemanager -> Netzwerkadapter (Ansicht = ausgeblendete anzeigen) -> alles in der Rubrik(Netzwerkadapter) deinstallieren -> Neu starten = alles installiert sich neu und funktioniert wieder(bei mir zumindest).

    Anmerkung:
    Hatte das auch vorher schon probiert, allerdings ohne die komplette Ansicht, demzufolge eben nicht alles deinstalliert. Warum das jetzt wieder funktioniert? Keine Ahnung und noch sonderbarer bleibt, warum das mit der Live-CD nicht funktioniert hat (CBild-Notfall-CD), sollte doch eigentlich windowsunabhängig sein, na ja egal, Hauptsache läuft wieder. Ist halt so eine Sache mit der Technik, steckt man nicht immer drin, siehe aktuelles Apple-Crash-Beispiel. 😉

    Gruss
    Henry

    -- Meine Meinung zu DSGVO & Co:
    „Principiis obsta. Sero medicina parata, cum mala per longas convaluere moras.“