Gunnar Bittersmann: Schriftschärfe in Firefox

Hm, jetzt hab ich den Firefox auf den 65er aktualisiert und kann nicht mehr vorher/nachher vergleichen. Hätte ich mal den 64er mit der 66er Developer Edition verglichen, da war mir der Unterschied schon aufgefallen.

Habt Ihr auch den Eindruck, dass die Schrift jetzt etwas unschärfer gerendert wird als früher (macOS, Retina-Display), inbesondere wenn man auf 110% oder 120% vergrößert, wie es bei vielen Webseiten nötig ist (auch bei diesem Forum)?

LLAP 🖖

-- „Wer durch Wissen und Erfahrung der Klügere ist, der sollte nicht nachgeben. Und nicht aufgeben.“ —Kurt Weidemann
  1. Hallo Gunnar,

    Habt Ihr auch den Eindruck, dass die Schrift jetzt etwas unschärfer gerendert wird als früher (macOS, Retina-Display)

    Nicht nur „etwas,“ sondern ganz gewaltig, ja. Ich kann das kaum ertragen und musste deshalb tatsächlich den Chrome ausgraben 😫

    LG,
    CK

    -- https://wwwtech.de/about
  2. Hi,

    Habt Ihr auch den Eindruck, dass die Schrift jetzt etwas unschärfer gerendert wird als früher (macOS, Retina-Display), inbesondere wenn man auf 110% oder 120% vergrößert, wie es bei vielen Webseiten nötig ist (auch bei diesem Forum)?

    nein.

    liegt vielleicht daran, daß ich in about:config bei den gfx.font_rendering.cleartype Werten einige nicht auf default habe (cleartypelevel 2 statt -1, enhanced-contrast auf 1 statt -1, gamma auf 1000 statt -1)

    cu,
    Andreas a/k/a MudGuard

    1. Hallo MudGuard,

      liegt vielleicht daran, daß ich in about:config bei den gfx.font_rendering.cleartype Werten einige nicht auf default habe (cleartypelevel 2 statt -1, enhanced-contrast auf 1 statt -1, gamma auf 1000 statt -1)

      Jetzt hatte ich gerade Hoffnung, dass du einen Hinweis zur Lösung lieferst. Dummerweise gibt den Config-String gfx.font_rendering.cleartype aber nicht unter macOS. 😟

      LG,
      CK

      -- https://wwwtech.de/about
      1. Hi,

        liegt vielleicht daran, daß ich in about:config bei den gfx.font_rendering.cleartype Werten einige nicht auf default habe (cleartypelevel 2 statt -1, enhanced-contrast auf 1 statt -1, gamma auf 1000 statt -1)

        Jetzt hatte ich gerade Hoffnung, dass du einen Hinweis zur Lösung lieferst. Dummerweise gibt den Config-String gfx.font_rendering.cleartype aber nicht unter macOS. 😟

        nur um das klarzustellen: das ist keine konkrete Einstellung, sondern eine Gruppe von Einstellungen, den genannten String im Filter eingeben …

        cu,
        Andreas a/k/a MudGuard

        1. Hallo MudGuard,

          nur um das klarzustellen: das ist keine konkrete Einstellung, sondern eine Gruppe von Einstellungen, den genannten String im Filter eingeben …

          Schon klar. Gibts nur nicht unter macOS:

          LG,
          CK

          -- https://wwwtech.de/about
          1. Unter Linux ebenso. Scheinbar überlässt der Browser das unter Unixoiden (Mac und Linux zählen ja dazu) dem OS bzw. dem "Desktop-Subsystem".

            1. Hallo ursus contionabundo,

              Unter Linux ebenso. Scheinbar überlässt der Browser das unter Unixoiden (Mac und Linux zählen ja dazu) dem OS bzw. dem "Desktop-Subsystem".

              Bei mir gibt es unter altem Linux und altem FF wenigstens Einträge mit "rendering"

              Linux FF60 about.config

              Bis demnächst
              Matthias

              -- Pantoffeltierchen haben keine Hobbys.
  3. Habt Ihr auch den Eindruck, dass die Schrift jetzt etwas unschärfer gerendert wird als früher (macOS, Retina-Display), inbesondere wenn man auf 110% oder 120% vergrößert, wie es bei vielen Webseiten nötig ist (auch bei diesem Forum)?

    Kein Unterschied hier unter Win7. Gerade hier um Forum bin ich aber eh im Chrome unterwegs, da mir das etwas schärfere Rendering im Chrome mehr liegt.

  4. Unter Windows 10 merke / sehe ich kein Unterschied. Was ich allerdings merke ist die Geschwindigkeit. Wahnsinn was sich da gegenüber der Vorgänger Version getan hat.

  5. Hallo Gunnar,

    ich habe gerade durch Zufall festgestellt: das gilt nur für das externe Display. Auf dem internen Display sieht die Schrift normal aus.

    LG,
    CK

    -- https://wwwtech.de/about
  6. Bei externem Monitor hatte ich das Problem von unscharfer Schrift auf dem Mac schon mal vor Jahren. Damals konnte ich das durch eine Systemeinstellung ändern - via Terminal.

    Habe eben nach dem Befehl gesucht und folgendes (neues) gefunden.
    (Kann es aber nicht testen, da ich keinen Mac vor mir habe.)

    Apple has disabled Subpixel antialiasing for text in macOS Mojave

    Folgendes via Terminal soll helfen:

    defaults write -g CGFontRenderingFontSmoothingDisabled -bool NO

    Quelle: https://dev.to/mrahmadawais/onedevminute-fixing-terrible-blurry-font-rendering-issue-in-macos-mojave--lck

    Ein ähnlicher Artikel: https://www.howtogeek.com/358596/how-to-fix-blurry-fonts-on-macos-mojave-with-subpixel-antialiasing/

    Vllt hilfts euch weiter.

    1. Hallo djr,

      Bei externem Monitor hatte ich das Problem von unscharfer Schrift auf dem Mac schon mal vor Jahren. Damals konnte ich das durch eine Systemeinstellung ändern - via Terminal.

      Ja, ne, ist hier leider nicht die Ursache, das externe Display ist auch hoch auflösend 😟

      Und es ist ja auch nur der Firefox und auch erst seit dieser Version.

      LG,
      CK

      -- https://wwwtech.de/about